locked
"null' values not retrieving from storage table using storage explorer query neither by PowerShell RRS feed

  • Question

  • Hello,

    Have created simple table in Azure storage. some property values are set to 'null' as you can see in below screenshot.

    but when I run the query to retrieve the records with 'null' value from column (Location in my example), it doesn't give desired output. strangely, it works when asked for non-null records.

     

    same thing happens when I use Powershell to query to the table,

    $filter = `
        [Microsoft.Azure.Cosmos.Table.TableQuery]::GenerateFilterCondition("Location",`
        [Microsoft.Azure.Cosmos.Table.QueryComparisons]::Equal,'null')
    Get-AzTableRow -table $APTable -customFilter $filter

    Something I'm missing here or doing fundamentally wrong?

    Thanks,

    Sachin

     



    • Edited by samtiger Friday, December 13, 2019 10:43 AM typo corrected
    Friday, December 13, 2019 7:54 AM

All replies

  • Firstly, apologies for the delay in responding here! Can you try 
    $filter = `
        [Microsoft.Azure.Cosmos.Table.TableQuery]::GenerateFilterCondition("Location",`
        [Microsoft.Azure.Cosmos.Table.QueryComparisons]::Equal, null)
    Get-AzTableRow -table $APTable -customFilter $filter

    Monday, December 16, 2019 6:57 AM
  • Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same, which might be beneficial to other community members reading this thread. And, if you have any further query do let us know.
    Tuesday, December 17, 2019 5:58 PM
  • Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same, which might be beneficial to other community members reading this thread. And, if you have any further query do let us know.
    Friday, December 20, 2019 12:38 PM