locked
Visual Studio 2008 IIS And Windows 7 RRS feed

  • Question

  • The installation of everything went quite nicely...everything works fine.
    Now the problem:
    let's say you have an ASP.NET project which is setup so you're debugging from IIS.
    I can't open the .SLN file directly because it keeps prompting me to run Visual Studio as an administrator.
    Well if i run Visual Studio as an administrator i have to them open the project to get it running...that's 3 clicks instead of one(a giant waste of time if you have more than one project open).

    Then you say...hey....i can set run as administrator on a shortcut...only to find out you can't do that with a visual studio solution shortcut.
    Ok i'll set compatibility mode AND/OR run as admministrator on devenv.exe.Look visual studio won't even start!
    Ok...then you say...i'll just write the string to the registry myself...only to find out that visual studio doesn't even run when you set all those again.
    Did anyone get sln files to run WITH UAC enabled...and if so how?
    Thank you! :)

    Monday, August 10, 2009 11:04 AM

Answers

  • Hi Looooooka,

    On Windows Vista or later, Visual Studio 2008 does not require administrator permissions to perform most tasks. However, if an operation does require elevated permissions, a message box will appear. In these instances, you may be prompted to restart Visual Studio 2008 with administrator permission to complete the task.
    See: http://msdn.microsoft.com/en-us/library/ms165100.aspx

    Based on your description, your operation needs elevated permission. If you don't want to do three clicks, you can try turning off UAC. It's by design.

    Hope this helps.

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Monday, August 17, 2009 5:43 AM
    Wednesday, August 12, 2009 5:58 AM