none
Will oracle DBMS_APPLICATION_INFO.SET_CLIENT_INFO cause no record return RRS feed

  • Question

  • My apps need to call a Stored Procedure in orcale which contains DBMS_APPLICATION_INFO.SET_CLIENT_INFO procedure

     

    both sql and Stored Procedure  is correct.

     

    the problem is when I try to exeute other sql, the return no row but It should have and no exception occur

    (when I use it in TODA it work)

     

    is it related to DBMS_APPLICATION_INFO.SET_CLIENT_INFO ? or any specfical handling I need to care of this call?

     

    OleDbConnection connection = new OleDbConnection(conn);
                connection.Open();

                OleDbCommand exe = new OleDbCommand(procedureName, connection);

                exe.CommandType = CommandType.StoredProcedure;

    ...
                 exe.ExecuteNonQuery();

     

                OleDbCommand cmd = new OleDbCommand(sql, connection);
                OleDbDataReader reader = cmd.ExecuteReader();

                while (reader.Read()) 
    ... 

     

     

    Saturday, February 16, 2008 4:29 AM

Answers

  • I download orcale offical db provider to solve this problem,

     

    it seems to me that microsft orcale provider may not fully support the procedure call in orcale.

    Tuesday, March 25, 2008 3:45 AM

All replies

  • Hi Clarc,

    did you solve the problem? I have it too, but not idea how to solve it.

    Best regards,

    Alex
    Tuesday, March 11, 2008 2:13 PM
  • I download orcale offical db provider to solve this problem,

     

    it seems to me that microsft orcale provider may not fully support the procedure call in orcale.

    Tuesday, March 25, 2008 3:45 AM