locked
Visual Studio 2005 installer asks to turn on .Net 1.1 Feature?

    General discussion

  • I just finished installing VC6 and VS2003 (I know, I know, just curiosity, not going to do production work in them, but at a glance they are still working), now I am installing Visual Studio 2005, and the installer prompts to enable the .Net 1.1 feature. I am surprised because if Windows 8 does detect feature installs it should detector .Net 2.0 for VS2005, not .Net 1.1. 

    And I could not find .Net 1.1 in the feature list under control panel->programs and features->turn windows features on/off, the only .Net versions there are .Net 3.5.1 and .Net 4.5. 



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP

    Friday, September 16, 2011 5:52 PM

All replies

  • Hi,

    I think you could try installing .NET 1.1 manually by downloading from Microsoft Update, but I'm not so sure it could work.


    Friday, September 16, 2011 6:20 PM
  • .Net 1.1 is already installed as a prerequisite of VS2003. 

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Friday, September 16, 2011 6:22 PM
  • .Net 1.1 is already installed as a prerequisite of VS2003. 

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP


    But, if the installer is asking for .NET Framework 1.1, it needs more components that maybe the VS2003 did not install.

    I have just tried install it manually, you will get a kind of compatibility issue message but if you run the installation it works:
    http://www.microsoft.com/download/en/details.aspx?id=26

    Regards,

    Friday, September 16, 2011 6:45 PM
  • Did you get a prompt to enable .Net 1.1? If any .Net version is prompted by VS2005 it should be .Net 2.0, not .Net 1.1. 



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Friday, September 16, 2011 7:08 PM
  • Did you get a prompt to enable .Net 1.1? If any .Net version is prompted by VS2005 it should be .Net 2.0, not .Net 1.1. 



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP

    No I didn't, .Net Framework 1.1 is not into Enable windows features, I downloaded it and installed it manually from Microsoft Downloads.
    I know it should be in VS, but If you are getting ask for .NET 1.1, maybe you can install it manually and see what happen.
    Friday, September 16, 2011 8:07 PM