none
Using the UpdateProjectProperty activity in Project Server workflow does not show the actual value of a custom field in PWA RRS feed

  • Question

  • Hi all,

    If I set the value of a custom feld using the UpdateProjectProperty activity, I don't see the actual value in PWA - neither in a Project Detail Page nor in a custom view in Project Center.

    There is quite a strange behaviour: If I open the project in Project Center (PWA), I see the old/wrong value of the custom field. Now if I click on Edit in the ribbon (which will check-out the project), the value of the custom field changes and displays the new/correct value. Well... strange.

    But it's getting stranger! I click on Save (assuming that the new value is saved as well) and Close (which will check-in the project) - the value of the custom field is still the old/wrong value! To get the new/correct value shown permanently I have to a) open the project in PWA, b) click on Edit, c) change any field (!, yes, any field, even to the same value), d) Save and e) Close/Check-in the project. Using this procedure will show the new/correct value of the custom field.

    There is quite a CheckInActivity missing in Project Server Workflow. This makes the UpdateProjectProperty worthless, because I don't see the actual values in PWA.

    Is anyone having a solution/workaround or some hints for me?

    With kind regards,

    Ronny

    Monday, December 6, 2010 11:41 AM

All replies

  • Hi Ronny,

    I am facing the same issue as above.

    Did u get any solution.

    Please reply.

    Regards,

    Sabnani Dinesh

    Thursday, September 8, 2011 4:04 PM
  • Hello Sabnani,

    each time I use the UpdateProjectProperty activity I've added a CodeActivity directly after it to check-in and publish the project via code. This is quite a workaround but the only way to get the actual values reflected in the UI.

     

    Regards,

    Ronny

    Monday, September 12, 2011 6:19 AM