none
Need help on getting "Set Netowork Location" wizard back (avoid automatic selection of "Public Network") RRS feed

  • Question

  • Hello,

    a couple of time ago our customer claimed that the "Set Network Location" wizard appears when a new device was connected to the network. So we figured out this can be suppressed by following registry keys:

    Add key HKLM\SYSTEM\CurrentControlSet\Network\NewNetworkWindowOff

    Now our customer reverted from his decision and wan'ts the "Set Network Location" wizard back (so that they can select the network type indivdually). So we removed that registry key mentoined above, but the wizard still does not appear, and every connection is automatically set to be "Public network" (well, it is possible to change this in Network sharing Center).

    We looked around for other possibilities, but nothing seems to help. Do you have any idea else than following - we tried:

    • Set "HideWizard" to zero (and also t ried to remove) entry in HKLM\SYSTEM\CurrentControlSet\Network
      -> No change
    • >Ensured that all policies below "Computer Configuration > Windows Settings > Security settings > Network List Manager Policies" are set to "Not configured" (we also removed existing networks listed there)'
      -> No change
    • Tried to disable/re-enable and also to uninstall/reisntall the network adapters
      -> No change
    • Tried to remve and import the registry keys mentoined above from a system that is not affected by this problem
      -> Nothing works any more (we assumed that this will happen)

    Thanks for any help.
    Best regards,

    Willi K.


    • Edited by Willi K Wednesday, June 27, 2018 12:16 PM
    Wednesday, June 27, 2018 12:14 PM

Answers

  • Hello,

    after some further investigations I found that there was a key "NwCategoryWizard" in HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network". After removing this key, the wizard appeared again.

    Hope this helps s/o at some time...

    • Marked as answer by Willi K Monday, July 2, 2018 1:30 PM
    Monday, July 2, 2018 1:30 PM

All replies

  • I would think that removing the registry key and then rebooting would have the wizard appearing again. I know this is for Windows 7, but the same solution is for Windows 10: https://www.tenforums.com/tutorials/92362-enable-disable-network-location-wizard-windows-10-a.html

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Wednesday, June 27, 2018 3:26 PM
    Moderator
  • Hello Sean,

    removing the "NewNetwokWindowOff" key from the registry (and rebooting, of course) was one of the first things we tried - unfortunately this didn't help.

    Another interesting thing: While trying the things mentoined above we have noticed that the wizard sometimes appeared as expected, but in this case it took a very long time until it happened (several minutes).

    Thursday, June 28, 2018 8:36 AM
  • Hello,

    after some further investigations I found that there was a key "NwCategoryWizard" in HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network". After removing this key, the wizard appeared again.

    Hope this helps s/o at some time...

    • Marked as answer by Willi K Monday, July 2, 2018 1:30 PM
    Monday, July 2, 2018 1:30 PM