locked
how to reference to Microsoft.WinJS.2.0, version 1.0.9600.17018

    Question

  • Hi,

    I am getting the following warning.

    DEP0810 : This app references Microsoft.WinJS.2.0, version 1.0.9600.16408, found in your SDK, but you have a higher version of Microsoft.WinJS.2.0 installed on the target machine, 1.0.9600.17018. If you continue to run this application, it will run against the currently installed version, Microsoft.WinJS.2.0, version 1.0.9600.17018. Consider updating your SDK to match the version of Microsoft.WinJS.2.0 that is installed. http://go.microsoft.com/fwlink/?LinkId=260891

    I installed "Visual Studio 2013 Extensions for the Windows Library for JavaScript" from http://www.microsoft.com/en-us/download/details.aspx?id=40793

    but still the same.  How do I reference to the newer version of WinJS 2.0.  I couldn't find the newer version in add reference from solution explorer.

    Friday, June 20, 2014 11:05 AM

Answers

  • Honestly it seem like just a warning since VS says that it's going to use the higher version.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, June 20, 2014 1:43 PM
    Moderator

All replies

  • Do you have VS2013 Update 2 installed?
    http://www.microsoft.com/en-us/download/details.aspx?id=42666

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, June 20, 2014 12:15 PM
    Moderator
  • Yes, with VS2013 Update 2 installed. Also did a repair installation. Still the same warning.

    Tried removing Windows Library for JavaScript 2.0 from references and added it back.  Didn't help.

    Friday, June 20, 2014 1:25 PM
  • Honestly it seem like just a warning since VS says that it's going to use the higher version.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Friday, June 20, 2014 1:43 PM
    Moderator
  • Yeah, shall ignore it.

    Previously WACK failed with app launch tests.  Was suspecting something to do with this WinJS warning.  It was something else. Thank you. 

    Saturday, June 21, 2014 4:11 AM