locked
Error while consuming webservice RRS feed

  • Question

  • User-886811842 posted

    Hi,

       I using SP 2013 and VS 2012 while consuming web service of which i created list items its throwing error if any one have idea about this please let me know.

    error message: 

      The document at the url http://Server........../_vti_bin/Lists.asmx?op=GetList was not recognized as a known document type.
    The error message from each known type may help you fix the problem:
    - Report from 'http://Server.........../_vti_bin/Lists.asmx?op=GetList' is 'The document format is not recognized (the content type is 'text/html; charset=utf-8').'.
    - Report from 'XML Schema' is 'The document format is not recognized (the content type is 'text/html; charset=utf-8').'.
    - Report from 'DISCO Document' is 'There was an error downloading 'http://Server.../_vti_bin/Lists.asmx?disco'.'.
    - The request failed with HTTP status 404: Not Found.
    - Report from 'WSDL Document' is 'The document format is not recognized (the content type is 'text/html; charset=utf-8').'.
    Metadata contains a reference that cannot be resolved: 'http://Server.............../_vti_bin/Lists.asmx?op=GetList'.
    The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'NTLM'.
    The remote server returned an error: (401) Unauthorized.
    If the service is defined in the current solution, try building the solution and adding the service reference again.

    Thanks

    SUJIL KUMAR.

    Tuesday, July 15, 2014 4:54 AM

Answers

  • User364480375 posted

    try this:

    1. Open Internet Information Services (IIS) Manager,

    2. Click the website

    3. Within Features, double-click Authentication

    4. Click "Anonymous Authentication" item

    5. If Status is Disabled, click Enable in Actions pane.

    6. Click Edit in Actions pane.

    7. Set "Anonymous user identity:" to "Application pool identity"

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 15, 2014 6:05 AM

All replies

  • User364480375 posted

    try this:

    1. Open Internet Information Services (IIS) Manager,

    2. Click the website

    3. Within Features, double-click Authentication

    4. Click "Anonymous Authentication" item

    5. If Status is Disabled, click Enable in Actions pane.

    6. Click Edit in Actions pane.

    7. Set "Anonymous user identity:" to "Application pool identity"

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, July 15, 2014 6:05 AM
  • User-886811842 posted

    Thank you very much... Laughing

    mike4u

    Friday, July 18, 2014 7:48 AM
  • User364480375 posted

    welcomeCool

    Friday, July 18, 2014 10:50 AM