none
CEPC on Win10 Hyper-V won't boot RRS feed

  • Question

  • I use a Virtual Machine for testing apps on Compact 2013.

    I have created the basic CEPC OS and used the same Virtual Hard Drive (.vhd) in Win7-VirtualPC, and Win8-Hyper-V (works great) BUT Now I attempted to do the same in Windows-10 Hyper-V, and the boot process hangs with no error messages.

    I have tried many variation since the initial failure, but can not get a Compact2013 OS to boot in Hyper-V on Windows-10.

    The Boot Loader runs, and I can change and save boot parameters, but the NK.bin does not fully load and run.

    >> COM1 Output >>

    Microsoft Windows CE Boot Loader Version 1.3 (Built Nov 20 2015 16:35:53)
    511MB, VRAM 4MB, PCI Extension 2.10, EDD Services 3.0, VESA 2.0, No APM Services

    Hit space to enter configuration menu 5...
    Hit space to enter configuration menu 4...
    Hit space to enter configuration menu 3...
    Hit space to enter configuration menu 2...
    Hit space to enter configuration menu 1...

    Debug Serial Init

    SysInit: GDTBase=82f43000 IDTBase=82f48b80 KData=82f41800
    Windows CE Kernel for i486
    INFO:OALLogSetZones: dpCurSettings.ulZoneMask: 0xb
    SearchPciBios end fails
     Bootloader reported 511MB
     RAM reported to kernel 511MB

    << END OUTPUT <<

    If I delete NK.bin, and configure the Bootloader to load image from PlatformBuilder/CELoader, it reaches 8% and then fails with a TFTP timeout.

    Basic VM hardware settings

    1 Processor, 512 MB RAM, BIOS-Boot from IDE,   IDE Controler0/myDisk.vhd, COM1->namedPipe, LegacyNetworkAdapter

    Attempted Variations:

    • 2 different Win10 machines (1 desktop, 1 laptop-clean install)
    • Tried both WCELDR and BLDR + boot.ini
    • With Splash.bmx and without
    • Tried both my original NK.bin and rebuilt a new NK.bin with all the latest patches for Compact2013 (update of Sept2015)
    • Tried disk format in FAT and FAT32
    • Tried different Hyper-V settings On and OFF (Dynamic Memory, Integration Services, RemoteFX 3D Video, ProcessorCompatibilityOn/Off NUMA Nodes=1,  etc.), and yes I realize most of these should not affect this at all, but just tried it anyway)

    Any help would be appreciated. Even if you just try and tell me "works on my machine, settings are  xxxx"

    UPDATE:

    After trying more things,

    1: After adding debugging to the loader, We DO actually finish loading and Jump to the OS, but it takes ~12 min to get past "BootFileSystemFat32::Create(psegment, psectorsize)" function in fat.cpp

    Once the OS starts, there was the first RETAILMSG out to the port, but I never saw it, because no "\n\r" made it print out (until I close the VM and the namedpipe flushes the buffer)

    2: It was discovered that the Default OS DOES Boot in Win10 Hyper-V,

    BUT if I use the Catalog Items View and enable "Core OS\Windows Embedded Compact\ DeviceDrivers\StorageDevices\ ATAPI PCI Support" then the system hangs same as before

    I tried leaving it running for 24Hrs to see if it was just a time/timeout issue, but it didn't have anything addition to see.

    Any ideas?
    • Edited by WxEric Friday, December 18, 2015 12:20 AM
    Wednesday, December 16, 2015 12:47 AM

All replies

  • I had similar problems

    What worked for me was to make sure that in the VM configuration, both ports (locations) of the IDE Controller 0 have a device attached.

    I used the following VM config
    IDE Controller 0, Location 0: Virtual Hard Disk (vhdx) holding the bootloader
    IDE Controller 0, location 1: DVD Drive, no media


    MVP Windows Embedded

    Thursday, February 4, 2016 10:45 AM