none
Visual Studio 2015 Publishing password NOT encrypted?

    Question


  • Hello,
    I'm running Visual Studio Community 2015 under Windows 10 Pro 64...

    I just tweaked a page of our web site, and then clicked to publish it.

    To my surprise, I next saw a warning that my password would be sent over the network as "unencrypted text."

    How can I modify things so that the password will be encrypted?

    Many thanks,

    Lothar


    Monday, June 27, 2016 11:26 PM

Answers

  • Hi,

    Though I do not have any real understanding of the cause of the problem, it now seems to be solved.

    I re-built my publishing profile, and the next time I tried to publish a page, the dialog I have shown did not appear.

    Many thanks,

    Lothar

    Friday, July 01, 2016 12:48 PM

All replies

  • Hi Lothar,

    Thanks for your post.

    >>To my surprise, I next saw a warning that my password would be sent over the network as "unencrypted text."

    Could you please tell me where did you find this warning message? If possible, please share us a screenshot of the UI or provide us the detailed steps to reproduce this problem.

    By the way, please try to publish a new created web site and check the test result.

    Best Regards,

    Lake Xiao

    Wednesday, June 29, 2016 2:22 AM
    Moderator

  • Thursday, June 30, 2016 2:08 PM
  • Hi,

    Here is the dialog that appears when I click to publish a page:

    I would appreciate any further help on this, 

    Lothar

    Thursday, June 30, 2016 2:14 PM
  • Hi Lothar,

    I can't find the window you shared in my side. When I click the publish the website. It shows like this:

    Please provide us the detailed steps to reproduce your problem so that we could better troubleshoot the issue.

    By the way, I suggest you could also try to post your problem to the ASP.NET Web Deployment forum for better support.

    http://forums.asp.net/1020.aspx/1?VS+Web+Deployment+Projects

    Best Regards,

    Lake Xiao


    Friday, July 01, 2016 2:56 AM
    Moderator
  • Hi,

    Though I do not have any real understanding of the cause of the problem, it now seems to be solved.

    I re-built my publishing profile, and the next time I tried to publish a page, the dialog I have shown did not appear.

    Many thanks,

    Lothar

    Friday, July 01, 2016 12:48 PM
  • Hi Lothar,

    Glad to hear your problem was solved. If possible, please mark your reply as the answer, so it would be helpful for other members who get the same issue as yours to research and find the answer directly, and I could close this case.

    Have a nice day.

    Best Regards,

    Lake Xiao

    • Marked as answer by Lothar Krepke Monday, July 04, 2016 1:08 AM
    • Unmarked as answer by Lothar Krepke Monday, July 04, 2016 1:08 AM
    Monday, July 04, 2016 1:06 AM
    Moderator
  • Hello again...,

    I just updated my VS software (because with my previous version, the problem of unencrypted passwords returned.)

    I am now running V 14.0.25431.01 Update 3.

    As soon as I installed this newer version, I tried to publish a page.

    I then saw the same dialog I posted above. I just tried to post that image again, but could not manage to do it. The important information in the dialog is that my password would be transmitted as plain text, and would not be encrypted. I have no understanding of what eliminated this problem the first time, and I need some help solving this now that the problem has returned.

    Sincere thanks,

    Lothar

    Thursday, February 09, 2017 9:53 PM