Error 0027 when running Time Series Anomaly Detection and what format should the input date be RRS feed

  • Question

  • Hi

    I am trying to implement Time Series Anomaly Detection (Azure ML Classic) but when I run the experiment, I get the error: 

    The size of "Data Column" is inconsistent with size of "Time Column". . ( Error 0027 )

    I have 2 columns in my dataset viz. DateTime and numeric data value (see below).

    What have tried as well?

    • I added an Edit Metadata step to convert my DateTime to type DateTime
    • I also tried the SLQ transformation (as proposed in the MS doco) to cast the below DateTime field to a SmallDateTime e.g. SELECT CAST([Time]  AS SmallDateTime) as [newTime] from t1;

    Neither of the above works. What am I doing wrong and can you please provide an example of the DateTime format that I should use as input to the Time Series Anomaly Detection module?

    Below is an example of my source data (numeric data value and DateTime value)


    Wednesday, May 27, 2020 4:48 AM

All replies

  • Hello sfogwill,

    According to the documentation the time series module expects the following:

    The dataset used as input must contain at least one column containing datetime values in string format, and another column that contains the trend values, in a numeric format.

    Could you please change the datatype to string and check if the run succeeds?


    Thursday, May 28, 2020 8:00 AM
  • Thanks for responding Rohit. Actually the MS document that describes how to implement this module specifies we should use the Edit Metadata module to set the type/format to DateTime - not string (see below extract from the MS document).

    Having said that - I did try setting it to String and got the same error.


    Monday, June 1, 2020 1:13 AM