Microsoft Symbols are not available RRS feed

  • Question

  • When accessing pdb symbols such as


    It seems this issue is not caused by my network.

    PDB: using PDBIDA provider

    PDB: downloading http://msdl.microsoft.com/download/symbols/wntdll.pdb/55DD471EC790617D75FB1DC5F4075EB91/wntdll.pdb => \\LocalServer\MS Symbols\wntdll.pdb\55DD471EC790617D75FB1DC5F4075EB91\wntdll.pdb

    PDB: HTTP error: A connection with the server could not be established  

    Would you please help solve this?


    • Moved by SadiqhAhmed-MSFTMicrosoft employee Thursday, April 23, 2020 10:02 AM Not an Azure query - Please assist routing to the appropriate forum to connect with the right experts
    Thursday, April 23, 2020 8:09 AM


All replies

  • Would be more than glad to help you with your issue.

    Could you please provide more details about the service you're using?

    What are you trying to accomplish?

    Please share screenshots if any?

    Thursday, April 23, 2020 8:31 AM
  • Hi,

    I used both windbg and IDA pro and also symchk.


    R:\>"A:\Program Files (x86)\Windows Kits\10\Debuggers\x86\symchk.exe" %WINDIR%\SysWOW64\gdi32.dll /s "SRV*https://msdl.microsoft.com/download/symbols"
    SYMCHK: gdi32.dll            FAILED  - wgdi32.pdb mismatched or not found
    SYMCHK: FAILED files = 1
    SYMCHK: PASSED + IGNORED files = 0


    Applying fixups...
      6. Creating a new segment  (004234B4-00426000) ... ... OK
    PDB: using PDBIDA provider
    PDB: downloading http://msdl.microsoft.com/download/symbols/notepad.pdb/084F38CE4F1BEEF73CE20121BE5901DC1/notepad.pdb => \\ThinkPad-T61\MS Symbols\notepad.pdb\084F38CE4F1BEEF73CE20121BE5901DC1\notepad.pdb
    PDB: HTTP error: A connection with the server could not be established  
    Could not find PDB file 'notepad.pdb'.
    Please check PDBSYM_SYMPATH in pdb.cfgAssuming __cdecl calling convention by default
    Type library 'vc6win' loaded. Applying types...
    Types applied to 215 names.
    Type library 'mssdk' loaded. Applying types...

    7756eaa2 cc              int     3
    CommandLine: C:\Windows\SysWOW64\notepad.exe
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*\\ThinkPad-T61\MS Symbols*http://msdl.microsoft.com/download/symbols/
    Symbol search path is: SRV*\\ThinkPad-T61\MS Symbols*http://msdl.microsoft.com/download/symbols/
    Executable search path is: 
    ModLoad: 00050000 0007b000   notepad.exe
    ModLoad: 774c0000 7765a000   ntdll.dll
    ModLoad: 75210000 752f0000   C:\WINDOWS\SysWOW64\KERNEL32.DLL
    ModLoad: 75c10000 75e0e000   C:\WINDOWS\SysWOW64\KERNELBASE.dll
    ModLoad: 75e50000 75e71000   C:\WINDOWS\SysWOW64\GDI32.dll
    ModLoad: 769a0000 769b7000   C:\WINDOWS\SysWOW64\win32u.dll
    ModLoad: 763d0000 7652a000   C:\WINDOWS\SysWOW64\gdi32full.dll
    ModLoad: 76620000 7669c000   C:\WINDOWS\SysWOW64\msvcp_win.dll
    ModLoad: 76080000 7619f000   C:\WINDOWS\SysWOW64\ucrtbase.dll
    ModLoad: 75a60000 75bf7000   C:\WINDOWS\SysWOW64\USER32.dll
    ModLoad: 769c0000 76a7f000   C:\WINDOWS\SysWOW64\msvcrt.dll
    ModLoad: 74cb0000 74f25000   C:\WINDOWS\SysWOW64\combase.dll
    ModLoad: 75920000 759db000   C:\WINDOWS\SysWOW64\RPCRT4.dll
    ModLoad: 74c90000 74cb0000   C:\WINDOWS\SysWOW64\SspiCli.dll
    ModLoad: 74c80000 74c8a000   C:\WINDOWS\SysWOW64\CRYPTBASE.dll
    ModLoad: 751b0000 7520f000   C:\WINDOWS\SysWOW64\bcryptPrimitives.dll
    ModLoad: 759e0000 75a56000   C:\WINDOWS\SysWOW64\sechost.dll
    ModLoad: 75fb0000 76034000   C:\WINDOWS\SysWOW64\shcore.dll
    ModLoad: 75130000 751a9000   C:\WINDOWS\SysWOW64\advapi32.dll
    ModLoad: 6fcc0000 6fecf000   C:\WINDOWS\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.18362.778_none_2e73ee38278978be\COMCTL32.dll
    (900.2dec): Break instruction exception - code 80000003 (first chance)
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll - 
    Processing initial command 'g $exentry'
    eax=00000000 ebx=028c8000 ecx=82bb0000 edx=00000000 esi=02be25c8 edi=774c688c
    eip=7756eaa2 esp=0279f728 ebp=0279f754 iopl=0         nv up ei pl zr na pe nc
    cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
    7756eaa2 cc              int     3
    0:000> g $exentry
    ModLoad: 75e10000 75e35000   C:\WINDOWS\SysWOW64\IMM32.DLL
    *** ERROR: Module load completed but symbols could not be loaded for notepad.exe
    eax=0000df1a ebx=028c8000 ecx=0006f8d0 edx=04040010 esi=0006f8d0 edi=0006f8d0
    eip=0006f8d0 esp=0279fc7c ebp=0279fc88 iopl=0         nv up ei pl zr na pe cy
    cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000247

    Accessing http://msdl.microsoft.com/download/symbols/notepad.pdb/084F38CE4F1BEEF73CE20121BE5901DC1/notepad.pdb directly in MSEdge browser will resut in "vsblobprodscussu5shard9.blob.core.windows.net closed the connection" for me.

    Thursday, April 23, 2020 9:00 AM
  • Hi

    I replied to you with logs,

    since my account is newly created, images cannot be post yet.


    Thursday, April 23, 2020 9:23 AM
    • Proposed as answer by Dave PatrickMVP Thursday, April 23, 2020 12:35 PM
    • Marked as answer by NeneisDead Friday, April 24, 2020 7:58 AM
    Thursday, April 23, 2020 10:17 AM
  • Hi

    Finally got the clue, *.blob.core.windows.net is blocked in my region.

    I added it to my VPN list and problem solved.

    Thanks a lot for the support.


    Friday, April 24, 2020 7:57 AM
  • Hi I'm only debugging with various tools like Visual Studio, windbg and IDA pro.

    They all require symbols from the store.

    It finally turned out to be a network issue. *.blob.core.windows.net is blocked in my region.

    I solved it by configuring a VPN.

    Thank you all!

    Monday, April 27, 2020 4:52 PM