locked
Multi-Language Web Site using app_GlobalResource RRS feed

  • Question

  • User-1900702984 posted

    I have downloaded and reviewed this tutorial http://www.asp.net/learn/videos/video-40.aspx several times.  It seems simple enough :) however the app_GlobalResource file is not working... so here it is.

    I downloaded the sample project c# version, the website run nicely except for the global part.  When I change the language in IE8 it doesn't change on the page.  What is missing, is there something in IE 8 that needs to be turned on or off?  I have Win7x64, VS08, IIS running asp 2.0 and IE8.

    When I am inside VS08 and use the expressions property the app_GlobalResource link is there (the default) but doesn't switch between the languages.. I am stumped!!

    Can anyone please help me solve this problem? 

    thanks in advance for your help :?

    Friday, January 22, 2010 4:05 PM

Answers

  • User-1900702984 posted

    LOL.. like i said.. I am new at the whole language thing.. but I found my problem..

    can we say "dah"... ;)

    The example works just fine.. I just didn't realize that the code behind was overriding the IE language settings.. so I added this to my master page settings..

    Culture="auto" UICulture="auto"

    and everything is working as it should in my test app.. now time to implement it in my project..

     

    again thanks for helping!!!! or trying at least :) 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 25, 2010 9:02 AM

All replies

  • User-126244515 posted

    I just downloaded the sample code and ran it; it works just fine. Now, I didn't convert it, but kept it in .NET 2.0. Did you convert it, or make any other changes to the code or configuration?

    ---EDIT---

    I just converted it to .NET 3.5 and it still works fine here, on Windows Server 2008 and with IE 8.

    Saturday, January 23, 2010 1:53 AM
  • User-1900702984 posted

    (bugger).. I tried both ways.. and no neither run.. and no I didn't change anycode.. i even tried my own project and it still doesn't work..  i am wondering if it has anything to do with my IE options.. can you email your security setting.. Tools -> options -> security -> custom level.. maybe there is something??

     

    thanks for checking this out for me.. i appreciate it!! very much!!

    Monday, January 25, 2010 8:29 AM
  • User-126244515 posted

    I sincerely doubt that would have any bearing on your issue, changing security settings in IE. Have you tried with a different browser? Is IE "restrained" by network policies?

    Monday, January 25, 2010 8:42 AM
  • User-1900702984 posted

    LOL.. like i said.. I am new at the whole language thing.. but I found my problem..

    can we say "dah"... ;)

    The example works just fine.. I just didn't realize that the code behind was overriding the IE language settings.. so I added this to my master page settings..

    Culture="auto" UICulture="auto"

    and everything is working as it should in my test app.. now time to implement it in my project..

     

    again thanks for helping!!!! or trying at least :) 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 25, 2010 9:02 AM
  • User-1900702984 posted

    FYI -

    master pages do not have the culture properties.. you have to add this to the web.config inside the system.web

    <system.web>
        <profile>
          <properties>
            <add
              name="UserCulture"
              defaultValue="auto" />
            <add
              name="UserUICulture"
              defaultValue="auto" />
          </properties>
        </profile>
    <system.web>


     

     

    Monday, January 25, 2010 11:15 AM
  • User-1900702984 posted

    More info for those who need it :)

    Getting the language setting out of IE

    Array 0 is the top of the list in the language setting box.. userlanguages stores all languages added to IE

     

    HttpContext.Current.Request.UserLanguages[0];


     

     

    Wednesday, January 27, 2010 11:19 AM