none
Can't Find 3.0 Service Pack 2 RRS feed

  • Question

  • I am trying to install .NET Framework 3.5 SP1 on an XP machine. I downloaded the program from the Microsoft website. Long story short is the installation errors out saying I do not have ".net framework 3.0 service pack2 installed." I have tried searching to no avail for SP2. My Machine currently has up to 3.0 SP1 and installed the 3.5 (not SP1) without issue.

    Does anyone know where I can get 3.0 SP2?

    Aarons Format:

    1. 3.5 SP1
    1. Microsoft Website
    3. Release (8/11/08)
    4. 2.0, 3.0 SP1, 3.5

    Edit: This is the error code I get every time I attempt to install 3.5 SP1;

    [11/08/08,16:51:01] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [11/08/08,16:51:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.

    Thank you for the help.
    • Edited by KD258 Sunday, November 9, 2008 1:42 AM
    Friday, November 7, 2008 1:35 PM

Answers

All replies

  • .NET Framework 3.0 sp2 will be applied if you install .NET 3.5 sp1 successfully.
    Based on the log information, the problem happened when .NET 3.5 sp1 setup attempted to install .NET 3.0 sp2, error code 1603 is a generic error.

    You may find this article useful: How to locate the cause of error code 1603 in a verbose MSI log file
    http://blogs.msdn.com/astebner/archive/2005/08/01/446328.aspx

    If you still have problem, please use collect tool and share the vslog.cab for more information: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Thanks.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    • Edited by Figo Fei Monday, November 10, 2008 5:47 AM typo
    • Marked as answer by Figo Fei Wednesday, November 12, 2008 2:02 AM
    Monday, November 10, 2008 5:44 AM
  • Since this machine was a little older, I just did a fresh reinstall of XP Pro. I have since successfully installed 3.5 SP1. Thanks for the help tho.

    I had looked up the 1603 error code and found articles about giving "full" access to the administrator in a registry file. I tried that and I never was able to find the string that Aaron talks about in the first link.

    Long story short is, I believe I had some registry problems and/or bugged files so I opted for clean reinstall.

    Thanks again
    Tuesday, November 11, 2008 1:44 PM