none
"Microsoft.Exchange.Management.PowerShell.Admin" problems in Exchange 2007 RRS feed

  • Question

  • Hi,
    1)I have developed a dotnet task for collecting Exchange server 2007 details using local powershell commands. I have refered the following URL and it works well for me in my Exchange 2007 installed machine(Windows server 2003 sp2 +Exchange server 2007 sp2).  
    http://msdn.microsoft.com/en-us/library/bb332449(v=exchg.80).aspx

    Now I have tried to tested my same task exe using all possible Exchange 2007 installed machines.
    So I have Installed windows server 2008(64 bit) standard edition and Installed Exchange 2007 sp2 with sucess fully in that machine. Now I have tested that exe and I got the below error
    "
    "No PSSnapin are present for version 1"

    I have  checked the Get-PSSnapin using Exchange management shell commond window and there is available the "Microsoft.Exchange.Management.PowerShell.Admin" Pssnapins.

    But at the same time I have check the same Get-PSSnapin command using windows powershell command window and there is not avali the "Microsoft.Exchange.Management.PowerShell.Admin" snapins
    I have tried to add using  C:\PS>add-PSSnapIn "Microsoft.Exchange.Management.PowerShell.Admin" snapins but here too I got the same error
    "No PSSnapin are present for version 1"

    So I concluded my dotnet task exe only refered the windows powershell cmdlts not Exchange management shell cmdlts.
    So how can I solve this problem.
    Is any thing I missed to configure the new exchange 2007 install?

    pls help me..

    by
    Joswa


    Sunday, September 4, 2011 1:39 PM

Answers

  • That error indicates your trying to load a 64 bit Snapin in a 32 bit powershell session which you can't do I would check the machine you developed it on as it sounds like your running the 32 bit (demo) version of Exchange. You'll need to recompile your code using 64 bit assemblies.

    Cheers
    Glen 

    Monday, September 5, 2011 3:29 AM

All replies

  • sorry for  my mistaken.

    I got the bellow error only not  "No pssanpins are registerd"

    Error: "No PSSnapin are present for version 1"

    pls help me..

    JoSwa.

    Sunday, September 4, 2011 2:06 PM
  • That error indicates your trying to load a 64 bit Snapin in a 32 bit powershell session which you can't do I would check the machine you developed it on as it sounds like your running the 32 bit (demo) version of Exchange. You'll need to recompile your code using 64 bit assemblies.

    Cheers
    Glen 

    Monday, September 5, 2011 3:29 AM