locked
Building process fo Android hangs RRS feed

  • Question

  • Hello,

    I haven't found any similar thread so I'll ask...

    I downloaded VS 2015 RC with Cordova, created new project from regular Cordova template. I have the Android SDK stuff v 19 and 21 installed. I haven't written a single line of code yet. When I try to build the app it hangs on

    [aapt] Generating resource IDs...

    Status bar says "Ready", while teh icon on the right is still moving. MSBuild takes 25% of CPU... And my computer can stayed in such state for a long while (I left and came back after 1 hour - nothing changed). 

    Such situation happens when I try to deploy to Android Emulator, while if I try to deploy to Ripple there are no problems at all.

    Any suggestions?

    Sunday, June 14, 2015 10:48 AM

All replies

  • Never experienced this issue.

    Let's see if we can get more specific information after enable diagnostics build log:

    In visual studio, go to menu Tools->Options-> Project and Solutions -> Select "Diagnostics" in MSBuild project build output verbosity.

    Try to reproduce the issue again and share the build log here for furthur investigation.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    Alan Yao
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, June 15, 2015 2:36 AM
    Moderator
  • I have this issue too, so thought I'd pitch in with my own logs. Similar to the OP, I've just done a brand new project and tried to get it to run.

    1>   (TaskId:10)
    1>  -set-mode-check: (TaskId:10)
    1>   (TaskId:10)
    1>  -set-debug-files: (TaskId:10)
    1>   (TaskId:10)
    1>  -check-env: (TaskId:10)
    1>   [checkenv] Android SDK Tools Revision 24.3.2 (TaskId:10)
    1>   [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk (TaskId:10)
    1>   (TaskId:10)
    1>  -setup: (TaskId:10)
    1>       [echo] Project Name: MainActivity (TaskId:10)
    1>    [gettype] Project Type: Application (TaskId:10)
    1>   (TaskId:10)
    1>  -set-debug-mode: (TaskId:10)
    1>   (TaskId:10)
    1>  -debug-obfuscation-check: (TaskId:10)
    1>   (TaskId:10)
    1>  -pre-build: (TaskId:10)
    1>   (TaskId:10)
    1>  -build-setup: (TaskId:10)
    1>  [getbuildtools] Using latest Build Tools: 21.1.2 (TaskId:10)
    1>       [echo] Resolving Build Target for MainActivity... (TaskId:10)
    1>  [gettarget] Project Target:   Android 5.0.1 (TaskId:10)
    1>  [gettarget] API level:        21 (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Creating output directories if needed... (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Resolving Dependencies for MainActivity... (TaskId:10)
    1>  [dependency] Library dependencies: (TaskId:10)
    1>  [dependency]  (TaskId:10)
    1>  [dependency] ------------------ (TaskId:10)
    1>  [dependency] Ordered libraries: (TaskId:10)
    1>  [dependency]  (TaskId:10)
    1>  [dependency] ------------------ (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Building Libraries with 'debug'... (TaskId:10)
    1>   (TaskId:10)
    1>  nodeps: (TaskId:10)
    1>   (TaskId:10)
    1>  -set-mode-check: (TaskId:10)
    1>   (TaskId:10)
    1>  -set-debug-files: (TaskId:10)
    1>   (TaskId:10)
    1>  -check-env: (TaskId:10)
    1>   [checkenv] Android SDK Tools Revision 24.3.2 (TaskId:10)
    1>   [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk (TaskId:10)
    1>   (TaskId:10)
    1>  -setup: (TaskId:10)
    1>       [echo] Project Name: MainActivity (TaskId:10)
    1>    [gettype] Project Type: Android Library (TaskId:10)
    1>   (TaskId:10)
    1>  -set-debug-mode: (TaskId:10)
    1>   (TaskId:10)
    1>  -debug-obfuscation-check: (TaskId:10)
    1>   (TaskId:10)
    1>  -pre-build: (TaskId:10)
    1>   (TaskId:10)
    1>  -build-setup: (TaskId:10)
    1>  [getbuildtools] Using latest Build Tools: 21.1.2 (TaskId:10)
    1>       [echo] Resolving Build Target for MainActivity... (TaskId:10)
    1>  [gettarget] Project Target:   Android 5.0.1 (TaskId:10)
    1>  [gettarget] API level:        21 (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Creating output directories if needed... (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Resolving Dependencies for MainActivity... (TaskId:10)
    1>  [dependency] Library dependencies: (TaskId:10)
    1>  [dependency] No Libraries (TaskId:10)
    1>  [dependency]  (TaskId:10)
    1>  [dependency] ------------------ (TaskId:10)
    1>   (TaskId:10)
    1>  -code-gen: (TaskId:10)
    1>  [mergemanifest] Found Deleted Target File (TaskId:10)
    1>  [mergemanifest] Merging AndroidManifest files into one. (TaskId:10)
    1>  [mergemanifest] Manifest merger disabled. Using project manifest only. (TaskId:10)
    1>       [echo] Handling aidl files... (TaskId:10)
    1>       [aidl] No AIDL files to compile. (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Handling RenderScript files... (TaskId:10)
    1>       [echo] ---------- (TaskId:10)
    1>       [echo] Handling Resources... (TaskId:10)
    1>       [aapt] Found new input file (TaskId:10)
    1>       [aapt] Generating resource IDs... (TaskId:10)
    1>   (TaskId:10)
    1>  BUILD FAILED (TaskId:10)
    1>  C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:597: The following error occurred while executing this line: (TaskId:10)
    1>  C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:649: The following error occurred while executing this line: (TaskId:10)

    Monday, June 15, 2015 8:28 AM
  • Same issue here!

    New installation and new copy of simple BlankCordovaApp1 -template.

    FYI: Ionic and Cordova work on command line.
    • Edited by MrHakala Monday, June 15, 2015 10:23 AM Added FYI
    Monday, June 15, 2015 10:21 AM
  • Seems to be a Android issue: 

    https://code.google.com/p/android/issues/detail?id=176488

    Monday, June 15, 2015 10:34 AM
  • @PointlessSpike,

    I believe the issue you mentioned is related to the Android SDK tool version. Don't use 24.3.2 for now. Please use 24.2 instead.


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    Alan Yao
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, June 15, 2015 1:11 PM
    Moderator
  • Thanks everyone, I'm using 24.2 and it's working. Hopefully this is the OP's problem as well.
    Monday, June 15, 2015 1:43 PM
  • Thanks for your answers. I changed the verbosity level - output is the same as pasted above. So I followed the suggestion to downgrade SDK Tools... Basically the outcome is nothing... Same error, just different line. 

    ...build.xml:601: The following error occurred while executing this line: (TaskId:10)

    Perhaps I should downgrade some other package as well? Any suggestions?

    Thanks in advance

    Tuesday, June 16, 2015 7:45 PM
  • So what's the new log? I need to check the detail. Thanks.

    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    Alan Yao
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, June 17, 2015 2:57 AM
    Moderator
  • Hello,

       On Visual Studio 2015, the build process was not stopping even when using Ctrl + Break. I killed the msbuild process from task manager. I enabled the msbuild output verbosity to see what errors were showing, and I noticed the missing components. I also noticed that there is a dependency checker for the Cordova tools. This also can tell us what is missing. I installed the missing components using the Android SDK manager tool. This fix the problem.

    For information here:

    http://www.ozkary.com/2016/01/visual-studio-2015-apache-cordova.html

    I hope this helps.


    og-bit.com

    Wednesday, January 13, 2016 4:27 AM