locked
VS11 Remote debugging met Access denied error

    Question

  • I have 2 Win 8 machines both installing the same copy of Developer Preview Build 8102. One of the machine is the Samsung tablet that obtained from the BUILD conference. I set it as the 'remote machine' in another system's VS11 Debug tab. Both of the machines can see each other.

    I launch the Remote debugger on the Samsung tablet. Then Press F5 from another system's VS11 project. I can the project shows "Deployment succeeded" at the lower left corner of VS11. And after I enter the SamSung tablet's user name and password, VS11 prompts the following error message:

    Attaching the x86 debugger to process '[xxx] testapp.exe' on machine 'test' failed. An unexpected DCOM error occurred trying to contact the remote computer. Access is denied.

    I stop the debugging and try again, the error message becomes:

    Attaching the x86 debugger to process '[xxx] testapp.exe' on machine 'test' failed. Access is denied.

    On the SamSung tablet, I can see the log message of the correct user has connected on Remote debugging monitor.

    Anything that I did wrong?

    Btw, SamSung tablet only has VS11 developer preview express while I am using VS11 ultimate version on the other system. Does that make any difference?

    Thank you.

    Wednesday, December 14, 2011 6:24 AM

All replies

  • Hi Angela,

     

    I'll run thru your steps to see what behavior I see. What type of project were you working with, a .Net or C++ app (and was it compiled for x86 or x64)?

     

    Are either of them joined to a domain?

     

    Update: I logged into both systems using the same domain user account so I did not get prompted for credentials. I had the same VS configuration as you described. My project was a Metro style app using C++ and configured for an x86 target. Everything deployed and worked as expected. I'll look into this further once I know how your settings differ from mine.

     

    Thanks,

    -David



    Wednesday, December 21, 2011 1:05 AM
    Moderator
  • Hi David,

    Thank you for your reply. Both of my systems are joining the same Workgroup named "WORKGROUP". And I have configured their IP address and they can see each other in their respective "Network" path in explorer. I am debugging a C# Metro Style Apps, and configured for x86 target. 

    Anyway, I am able to successfully debug the default C# template Metro style Apps, so I think my system setup should not be a problem. The problem mostly lies in my own C# Metro Apps. (But when I copied my entire C# project to the Samsung machine and start local debug, there is no issue at all. So I am a bit confused here.)

    I tried to repro this issue by creating a default C# Metro Apps using the Grid template and was able to debug using remote machine. Then I add a binary reference (a random Dll from host computer) in the Metro Apps and tried to debug again. This time it prompts me deployment error occurs: 

    "APPX" attributes were found in the SDK manifest file however none of the attributes matched the targeted configuration and architecture and no "APPX" attribute without configuration and architecture could be found. If an appx is required then the project will fail at runtime.

    I thought maybe I should not include the dll in the package, so I removed it from the project and tried to debug again. The same deployment error still shows. 

    Any idea how I can get rid of the error?

    Thank you.

    Thursday, December 22, 2011 3:13 AM