locked
Unable to resolve dependencies. 'EntityFramework 6.1.3' is not compatible with 'LinqKit 1.1.15 constraint, 'Microsoft.AspNet.Identity.EntityFramework 2.2.1 constraint: EntityFramework (>= 6.1.0)'. RRS feed

  • Question

  • User-1651604128 posted

    Hi,

    In my MVC web app, I need to call Powershell for doing automation task of access another db, so I am trying to import "System.Management.Automation" from NuGet, but when I click install from NuGet, I got this error, the import is failed,

    Unable to resolve dependencies. 'EntityFramework 6.1.3' is not compatible with 'LinqKit 1.1.15 constraint:
    EntityFramework (>= 6.2.0)',

    'Microsoft.AspNet.Identity.EntityFramework 2.2.1 constraint: EntityFramework (>= 6.1.0)'.

    Does anybody know what happened with my visual studio? by the way, I am using Visual Studio 2015,  this is entityFramwork from webconfig file:

    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />

    The Target framework: under Application Property shows : .NET Framework 4.6.1 

    The EntityFrameWork.dll under Reference shows: Version: 6.0.0.0, Runtime Version: v4.0.30319

    Should I update my entityframework by import new version EntityFrameWork from NuGet?

    Thanks

    Wednesday, October 2, 2019 3:16 PM

Answers

  • User753101303 posted

    Yes IMHO  always follow version requirements. It should have been updated when this version was installed...

    Edit: not an issue here but sometimes it's best to upgrade in the reverse order so that you don't have to upgrade too many packages at a single time but rather work on them one by one (for example here the latest version of LinqKit requires an EF upgrade but you could have upgraded EF first to focus on that and then LinqKit possibly later etc...)

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 3, 2019 9:51 AM

All replies

  • User753101303 posted

    Hi,

    Seems unrelated. Could it be a problem you had already and that is shown as well when kicking nuget?

    Looking at https://www.nuget.org/packages/LinqKit/ it seems EF 6.2 is needed since LinqKit 1.12.



    Wednesday, October 2, 2019 3:33 PM
  • User-1651604128 posted

    Hi,

    Seems unrelated. Could it be a problem you had already and that is shown as well when kicking nuget?

    Looking at https://www.nuget.org/packages/LinqKit/ it seems EF 6.2 is needed since LinqKit 1.12.

    Hi PatriceSc,

    Thanks a lot for your help, I think I should update my EF to the new version at least EF 6.2?

    Wednesday, October 2, 2019 7:55 PM
  • User753101303 posted

    Yes IMHO  always follow version requirements. It should have been updated when this version was installed...

    Edit: not an issue here but sometimes it's best to upgrade in the reverse order so that you don't have to upgrade too many packages at a single time but rather work on them one by one (for example here the latest version of LinqKit requires an EF upgrade but you could have upgraded EF first to focus on that and then LinqKit possibly later etc...)

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, October 3, 2019 9:51 AM