none
Message received by "FILE" adapter is suspended RRS feed

  • Question

  • Hi All,

    I am getting the following error on biztalk server 2006 R2 in my production enviornment, during message
    receive through FILE adapter:

    A message received by adapter "FILE" on receive location "MyReceiveLocation"
    with URI "MyURI*.xml" is suspended.
    Error details: 80004005
    MessageId: {362E0EB6-1A58-4B00-94FB-33B0D4FB83B3}
    InstanceID: {52DEA059-AC41-4D62-B3E1-A487D12CDE8D}

    Appreciates any thoughts or advice.

    Cheers,
    Indika.
    Monday, February 2, 2009 11:11 PM

All replies

  • The error number 80004005 usually means the file has an improper structure. For your message, are you sure it is an Xml file? Also, are you using the XmlRecieve pipeline?

    I have also seen this error number for some security issues. Could you also confirm the BizTalk app host account has permissions to the folder it is reading from?

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, February 3, 2009 4:37 AM
    Moderator

  • Thanks for your comments.

    Yes Ben. For sure always its a xml file and i am using a custom receive pipeline. BizTalk app host account has full permissions too. This error doesn't happening always and there is no sequence of triggering the issue. Its happening randomly. I have a custom orchestration to resume suspended messages. so even messages getting suspended unexpectedly in this way within few minutes/seconds it will resumed and delivered to destination successfully. No data loss. No any other logs any where. But time to time this Error is triggered.

    Thanks.
    Tuesday, February 3, 2009 6:01 AM
  • Most likey a performance issue, any change with interval settings?
    Kerrey [BizTalk Consultant]
    • Proposed as answer by edhickey Tuesday, February 17, 2009 12:04 AM
    Thursday, February 5, 2009 6:16 PM
  •  

    I was having a problem like this in past and I resolved it by turning off my Anti-Virus, also check that the indexing service is disabled too.

     

    -FIras


    Please mark answers that solve your problem.
    • Proposed as answer by edhickey Tuesday, February 17, 2009 12:04 AM
    Wednesday, February 11, 2009 3:32 PM
  • If this is a random error it might be the network problem.
    Is this Receive location on the same box or on the NAS for instance?
    Check the network events for the same time with your error.

    Leonid Ganeline [BizTalk MVP] http://geekswithblogs.net/leonidganeline
    • Proposed as answer by edhickey Tuesday, February 17, 2009 12:05 AM
    Monday, February 16, 2009 5:34 AM
  • Hi Kerrey,
    Only change is Process Memory Usage throttling value in BizTalk host is changed to 80 (Default value is 25). As i know it will increase the performance.
    Tuesday, February 17, 2009 12:37 AM
  • Yes Firas, my indexing service is disabled. Is there any impact on it?

    Thanks
    Indika..
    Tuesday, February 17, 2009 12:42 AM
  • I am also thinking that this is a network issue. but there is nothing to prove that.
    Receive location is not in same box. It is in another server. No network events in that time.

    Thanks
    Tuesday, February 17, 2009 12:54 AM