locked
Windows Phone 8 emulator internet connectivity issue RRS feed

  • Question

  • Hi,

    We have just installed windows phone 8 SDK on my i5 processor PC with windows 8. But the internet doesn't work. Do we have to make any specific configuration to make it work?

    We have tried many options which we found here in the forum and on stackoverflow.

    In one of the method we followed, we turned on Internet sharing in one of the virtual network adaptor and tried to start the emulator using Hyper-V. It started successfully and we were able to use the net. But when we try to follow the same procedure and start the emulator using visual studio and try to deploy any app, the emulator crashes giving this error:

    "the windows phone emulator wasn't able to connect to the windows phone os 

    they didn't respond to the connect request"

    Please provide a solution to our problem. Also please note tat we are not using any proxy for the machine in which the SDK has been installed.


    Monday, November 26, 2012 2:57 PM

Answers

  • I think I've finally found the answer from one of the stackoverflow questions (http://stackoverflow.com/questions/13159947/windows-phone-8-emulator-cant-connect-to-the-internet).

    "It would appear that the phone emulator requires you to have a second network adapter to dedicate to this purpose. Personally, I run Windows 8 in VMWare, and so a second network adapter is free for me.

    Anyway, after you get the second network adapter that you can dedicate for the phone emulator(must have internet)

    1. Start from scratch. Go to the Hyper-V manager and delete the emulator along with all of the virtual switches
    2. Start the emulator from Visual Studio; this will recreate it with all default settings(select yes you want to configure it to connect to the internet)
    3. Shut it down
    4. Now, go back to the Hyper-V manager
    5. Delete the snapshot that was just created for the emulator. This will prevent your changes from disappearing
    6. Find the virtual switch for your second network adapter in the Network Adapter settings(under control panel)
    7. Disable TCP/IPv4 and 6. This prevents your host machine from trying to use the connection. While you're there, get the MAC(Physical) address of this adapter
    8. Find the virtual-switch for your second network adapter under the Hyper-V settings for the emulator
    9. Change the MAC type to static and paste in the MAC address of the adapter
    10. Enable MAC spoofing (not sure if required, but just in case)
    11. Click OK and then start the emulator from Visual Studio!

    Basically, it appears that for some odd reason it won't properly work unless the phone has the same MAC address as the network adapter. However, we can't just set it to use the same MAC address because address conflicts are very very bad. So, we need a second adapter that we can dedicate to the Phone emulator. The reason we disable TCP/IP on this adapter is so our host machine doesn't use it and cause these conflicts"

    Why did this happen? Can you justify or explain how did this solution work?

    Friday, January 11, 2013 4:43 AM

All replies

  • Hi,

    The following MSDN links have been recently published to address the most common issues.

    System requirements for Windows Phone Emulator

    How to enable Hyper-V for the Windows Phone Emulator

    Let us know if they help.

    -Mark


    Mark Chamberlain Sr. Escalation Engineer | Microsoft Developer Support | Windows Phone 7

    Monday, November 26, 2012 6:44 PM
  • Hi Mark, thank you for your reply. We have configured our pc correctly. And we have referred the above link also. We are not facing any issue with Hyper V or emulator but the emulator is not able to take the pc's net. How can we configure it to do so automatically. Please help.
    Tuesday, November 27, 2012 7:12 AM
  • For this problem,  I would recommend that you open a support case. It's very difficult to troubleshoot problems in the forum that are specific to particular machines.  A support case would allow us to come in and view your specific configuration and make changes.

    http://msdn.microsoft.com/library/windowsphone/help/jj159132


    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Tuesday, November 27, 2012 4:41 PM
    Moderator
  • I had the same issue. I had to uninstall my other virtual machine client. Everything has been fine after that.

    Friday, December 14, 2012 7:09 AM
  • I think I've finally found the answer from one of the stackoverflow questions (http://stackoverflow.com/questions/13159947/windows-phone-8-emulator-cant-connect-to-the-internet).

    "It would appear that the phone emulator requires you to have a second network adapter to dedicate to this purpose. Personally, I run Windows 8 in VMWare, and so a second network adapter is free for me.

    Anyway, after you get the second network adapter that you can dedicate for the phone emulator(must have internet)

    1. Start from scratch. Go to the Hyper-V manager and delete the emulator along with all of the virtual switches
    2. Start the emulator from Visual Studio; this will recreate it with all default settings(select yes you want to configure it to connect to the internet)
    3. Shut it down
    4. Now, go back to the Hyper-V manager
    5. Delete the snapshot that was just created for the emulator. This will prevent your changes from disappearing
    6. Find the virtual switch for your second network adapter in the Network Adapter settings(under control panel)
    7. Disable TCP/IPv4 and 6. This prevents your host machine from trying to use the connection. While you're there, get the MAC(Physical) address of this adapter
    8. Find the virtual-switch for your second network adapter under the Hyper-V settings for the emulator
    9. Change the MAC type to static and paste in the MAC address of the adapter
    10. Enable MAC spoofing (not sure if required, but just in case)
    11. Click OK and then start the emulator from Visual Studio!

    Basically, it appears that for some odd reason it won't properly work unless the phone has the same MAC address as the network adapter. However, we can't just set it to use the same MAC address because address conflicts are very very bad. So, we need a second adapter that we can dedicate to the Phone emulator. The reason we disable TCP/IP on this adapter is so our host machine doesn't use it and cause these conflicts"

    Why did this happen? Can you justify or explain how did this solution work?

    Friday, January 11, 2013 4:43 AM
  • I ran into this issue, and was able to correct it by removing a bridge on my wireless connection adaptor. 

    1. Go to the Control Panel
    2. Go to Network and Sharing Center
    3. Click on Change Adaptor Settings (left panel)
    4. If you see a bridge connection on your wireless adaptor then right-click on the adaptor and remove the bridge connection.

    This worked like a charm for me.  Hope this helps someone.

    ~Cheers!!

    • Proposed as answer by Chris Rogala Sunday, April 5, 2015 1:29 PM
    Sunday, April 5, 2015 1:29 PM