locked
How to use rich text box in word templates using Quick Parts? RRS feed

  • Question

  • Hi All,

    I am able to create a rich text box in document library but in word template not reflect rich text box in word column(Quick Part),
    I have attached my custom document content type in that document library.
    I want to show the rich text column in the Word document template.

    1.In documents library view properties display me correct text in rich text.

    2.But not display in word template, In following is a snap

    Please help me

    Thanks

    Vikram

    Wednesday, April 18, 2012 6:58 AM

Answers

  • Hello Vikram,

    Thanks for the additional info. I looked into this and found when we add the Rich Text field to an existing library, no Rich Text editing tools tabs come up however when the same document library is saved as template and another document library is created using that template, in that one we see that, Rich Text editing tools tabs does come up; I am not sure if this behavior is expected and this is what seems to be inducing the issue what you see in the Word application.

    We have confirmed that the behavior you have reported is reproducible at our end and requires in depth troubleshooting. This has been reported to the Product Group however, If you wish to pursue this, please open up a Premier Support Incident with Microsoft for continued troubleshooting on this issue. Alternatively, you could visit the below link to see the various support options that are available to better meet your needs: http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone; if you are a MSDN / TechNet subscriber, you can also contact our support by using your free support incidents.


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Tuesday, April 24, 2012 8:22 AM

All replies

  • Hello,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Sally Tang

    Thursday, April 19, 2012 1:04 PM
  • Hi Sally.

    I am waiting for your reply.

    Thanks

    Balaji

    Friday, April 20, 2012 5:33 AM
  • Hello Vikram,

    1) Could you please tell me how have you enabled Rich Text fields for document library? (generally these are available for only lists)
    2) Are you expecting quick parts in Word to show rich text instead of showing HTML tags
    OR
    2) Are you expecting word template to show rich text when opened in word (please see below screenshot)


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Monday, April 23, 2012 3:20 PM
  • Hi Nishant,

    I am creating a custom column with rich text box and attached to my custom content type.

    That content type i am use my document library,but still not enable rich text box column.

    Save that document library as a template and create another document library using that saved template.

    Then document library will enable the rich text box column.

    I am expecting word template to show rich text when opened in word through quick part.

    Thanks

    Vikram



    Tuesday, April 24, 2012 5:43 AM
  • Hello Vikram,

    Thanks for the additional info. I looked into this and found when we add the Rich Text field to an existing library, no Rich Text editing tools tabs come up however when the same document library is saved as template and another document library is created using that template, in that one we see that, Rich Text editing tools tabs does come up; I am not sure if this behavior is expected and this is what seems to be inducing the issue what you see in the Word application.

    We have confirmed that the behavior you have reported is reproducible at our end and requires in depth troubleshooting. This has been reported to the Product Group however, If you wish to pursue this, please open up a Premier Support Incident with Microsoft for continued troubleshooting on this issue. Alternatively, you could visit the below link to see the various support options that are available to better meet your needs: http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone; if you are a MSDN / TechNet subscriber, you can also contact our support by using your free support incidents.


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Tuesday, April 24, 2012 8:22 AM
  • Hi Vikram

    I'm having the same issue. BTW, Just an additional info, you can add multiline enhanced rich text into your document library using SPD 2010 itself... You dont have to save as template and create another doc library....

    Please Let me know if you find a solution for the displaying rich content in word document...

    Hi Nishant, Any thoughts?


    Wednesday, May 2, 2012 5:03 PM
  • Hi TarSam,

    Thanks for the additional info. As I mentioned, I have already reported this behavior to product group and its under investigation. If this is urgent then please feel free to open a premier support incident...


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Regards,
    Nishant Shah
    Microsoft Online Community Support

    Thursday, May 3, 2012 8:14 AM
  • I had to display the word TABLE  format which i couldn't do that...finally ended up doing "old-fashioned" tab delimited/ carriage returns..that works....:)
    • Edited by GeekPeek Monday, May 7, 2012 2:01 PM
    Monday, May 7, 2012 1:54 PM
  • Hi Tarsam,

    If you solve this issue how to use rich text in word template using quick part then

    Please tell me how can i achieve this.Please provide me some code or solution in brief.

    Thanks

    Balaji

    Wednesday, May 23, 2012 6:46 AM
  • I also am trying to accomplish the same thing.  has anyone found a solution yet?
    Thursday, January 17, 2013 3:26 AM
  • I have exactly the same problem. Is there any solution yet?
    Thursday, January 30, 2014 9:12 AM
  • Hi Nishant (or any one from Microsoft),

    Was this issue resolved? I am asked by my client to include some context fields in word template. Some of the text fields are Rich Text and word is displaying them as HTML.

    It is exactly same issue that reported here and I am wondering if there is any solution without writing custom code?

    Thanks.

    Yogi

    Monday, March 9, 2015 3:49 PM
  • Even I have the same issue. Still didn't get a solution. Having any idea to fix this?

    Thanks,

    Abi


    Monday, March 30, 2015 6:38 PM
  • Has there been a solution posted since 2012....?It's 2016 and I am trying to do the same thing as this person was trying to do back in 2012!!

    How do we get the rich text field to be available on the quick parts. I would like to map this field to a SharePoint column and be able to have the data displayed back in the word doc.

    If this is possible it would change the way we do business!

    thanks for your help

    Dawn

    Tuesday, June 7, 2016 3:29 PM
  • Any luck finding a solution? I too am trying to do this and am not having any luck finding an answer.

    Thanks. 

    Monday, October 3, 2016 6:46 PM