locked
SQL Server 2012 Repair Error - INSTALLSHAREDDIR parameter is not valid because this directory is compressed RRS feed

  • Question

  • I've been trying to repair my SQL SERVER 2012 installation, I've had it for years  and all of a sudden the Management Studio application will not open and suggests that i reinstall. But when i try to either REPAIR or REINSTALL, i get the error message below:

    ------------------------------

    The specified directory, "C:\Program Files\Microsoft SQL Server\", for the INSTALLSHAREDDIR parameter is not valid because this directory is compressed or is in a compressed directory. Specify a directory that is not compressed.

    --------------------

    I have read a few forums online that recommend moving the Config.ini file and editting it, but the Config file i find does not have any refernce to Installshare directory. What do i need to do to get this pointing to the right location.

    Friday, September 16, 2016 4:17 PM

Answers

  • SQL SERVER - Installation Error - INSTALLSHAREDDIR parameter is not valid because this directory is compressed or is in a compressed directory compress-01

    http://blog.sqlauthority.com/2015/02/16/sql-server-installation-error-installshareddir-parameter-is-not-valid-because-this-directory-is-compressed-or-is-in-a-compressed-directory/


    Please click Mark As Answer if my post helped.

    • Marked as answer by LZee Friday, September 16, 2016 5:28 PM
    Friday, September 16, 2016 4:31 PM

All replies

  • SQL SERVER - Installation Error - INSTALLSHAREDDIR parameter is not valid because this directory is compressed or is in a compressed directory compress-01

    http://blog.sqlauthority.com/2015/02/16/sql-server-installation-error-installshareddir-parameter-is-not-valid-because-this-directory-is-compressed-or-is-in-a-compressed-directory/


    Please click Mark As Answer if my post helped.

    • Marked as answer by LZee Friday, September 16, 2016 5:28 PM
    Friday, September 16, 2016 4:31 PM
  • Thank you so much! didnt realize these folders were compressed! IT fixed the issue!
    Friday, September 16, 2016 5:28 PM