none
AOC G2460VQ6 RRS feed

  • Question

  • Good afternoon,

    I have recently bought an AOC G2460VQ6 monitor. It comes with FreeSync and runs at 75Hz. However, Windows 10 installed drivers for a generic PnP monitor, and says it runs at 59Hz. Of course I want to make use of the FreeSync and the 75Hz so I downloaded the driver for this monitor from AOC's support site.

    However, Windows 10 will not allow the installation of unsigned drivers, which normally shouldn't pose much of a problem, but to my dismay I am unable to select option 7 (F7) from the Windows Startup settings, simply because my USB keyboard isn't activated during the startup phase. Can someone tell me how to solve this problem? Is there an update? A fix? Or do I need to get in touch with AOC and ask them to sign their drivers?

    Many thanks in advance,

    Arien.

    Friday, March 16, 2018 4:43 PM

All replies

  • Hi Arien.

    A long and complicated story.

    I have been dealing with this problem for the last two to three weeks after the latest Windows 10 update.  My monitors are different to yours, but this might help.

    My solution was to use 60Hz Ultra HD, and not 75Hz Ultra HD, set through the NVIDIA Control panel and NOT the Microsoft Windows 10 Control Panel Display Setting menu. (Note if you try to set 60Hz in the Microsoft Control Panel this does not change the settings on the NVIDIA card. I know it sounds weird, but I had to change the display refresh rate through the NVIDIA video card menu.

    I found two drivers for the AOC G2460VQ6 monitors, G2460VQ6 Driver.zip and G2460VQ6 beta Driver.zip (the 75Hz fix) from AOC - EU site, http://www.aocmonitorap.com/my/download_driver.php,

    I tried installing the ‘beta’ AOC 75Hz update driver from AOC but got the usual ‘not digitally signed’ issue, and having USB keyboard and mouse like you, could not access the F7 function. In the end I had to resign to Ultra HD 60Hz.

    It might also be a good thing to check the native refresh rates on your monitors. My two AOCG2460VQ6 displays have native 68Hz horizontal and 60Hz vertical as default so 75Hz set by Microsoft would not work. I expect that this can be changed but the menu system on the AOC monitors is a bit clunky and I did not want to mess up the default settings on the G2460VQ6 creating another problem.

    From memory, and that might not be that good, I cannot remember seeing this Ultra HD vs PC display options before the latest Windows 10 update?

    In conclusion I think the issue comes with the new Microsoft display drivers that have the two display options, Ultra HD and PC.  My system, adjusted through the NVIDIA Control Panel, has the displays on Ultra HD at 60Hz. (Note: I had to set each display in turn). If this works, I will let you know in about tomorrow.

    PS: I have a post on Whirlpool Forum under Lumpy20.

    Regards, KH


    • Edited by Lumpy20 Saturday, November 17, 2018 2:39 AM
    Saturday, November 17, 2018 2:24 AM
  • Hi Arien,

    So far it is working.

    I may have to still go in and change some power settings. Some posts think that the default setting 'fast startup from sleep' option installed in the latest Windows 10 update might also be an issue.

    Regards, KH

    Saturday, November 17, 2018 3:42 AM