none
Tasks are not getting cancelled in Parallel approver process

    Question

  • Dear All

    We have an SharePoint online application and for the list an Parallel approval Designer 2013 workflow(an info-path form of list) is attached .

    Once one of the task gets  approved by the one of the app-rovers,the others tasks should get cancelled.

    It was working fine but it is not working from past one month.

    Please suggest us the fix ASAP.It is very urgent.

    Thanks in advance

    GS


    Sowjanya G

    Monday, April 17, 2017 4:58 AM

All replies

  • Hi GS,

    Please go to SharePoint Designer, find the workflow and edit, check if you select “wait for first response” in task options section.

    If not, please select it and check if the issue exists.

    If you have already selected, re-publish this workflow and start again.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 18, 2017 3:17 AM
  • Thanks for your reply.

    As you said,all the task options were already checked with the Option "Waiting for first response".

    Republished the workflow yesterday and still facing the same issue.

    And it is working fine in the QA.

    QA and prod are under the same web application.

    Currently we are facing this issue in the prod and we found sometimes there is an time lag between the parallel tasks creation too

    Need your help.It is urgent.

    Thanks in Advance

    GS


    Sowjanya G


    • Edited by GSouji Wednesday, April 19, 2017 5:41 AM
    Wednesday, April 19, 2017 5:33 AM
  • Hi GS,

    Try to follow the steps below to clear the SharePoint Designer cache, then republish this workflow, check if the issue exists:

    https://social.technet.microsoft.com/wiki/contents/articles/33469.how-to-clear-your-sharepoint-designer-20102013-cache.aspx

    If the issue exists, create a new workflow with the start approval process action and check.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Sunday, April 23, 2017 10:07 AM
  • HI Grace Wang

    Thanks a lot for your help.

    After clearing the cache also the same issue persists and we cannont create new worklfow as it is the production environment.

    This workflow is designed in sharepoint designer 2013 version,the other applications which has the same workflow in 2010 version is working fine.

    The 3 applications which are created using sharepoint designer 2013 version of paralllel approver process faces this issue.

    And we are not able to replicate the issue in QA environment which lies under the same webapplication of prod.

    Please suggest solution ASAP.

    Appreciate your help in advance.

    Thanks

    GS


    Sowjanya G

    Wednesday, April 26, 2017 5:29 AM
  • Hi GS,

    I suggest you recreating the workflow to make sure if this is the issue with only one workflow or all workflows.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, May 05, 2017 12:11 PM