none
Driver Nightmare RRS feed

  • Question

  • This is by far the most frustrating and fruitless device installation I have ever made.

    I know this should be as simple as apple pie but I just don't know what else to do, since I'm having the exact same issue on two different machines, using two different Kinects...

    Device Manager shows a Microsoft Kinect group with three devices: Camera, Audio Control and Device. The problem is that on both machines the system keeps on showing and then hiding the camera and it goes on forever.

    Reboot doesn't fix it.

    Re installation either.

    This has been very difficult and I haven't even started yet! Please help me solve this once and for all!

    Thanks all!

    L


    LM
    Sunday, November 13, 2011 10:27 PM

All replies

  • Hello LM,

    Can you provide us data on what type of USB controller you have? Also, have you tried to plug in the Kinect into a different USB port?

    Robert.

    Monday, November 14, 2011 3:17 AM
  • Hi Mr. Wlodarczyk,

    I have a Mac Pro running Boot Camp Windows 7 x64 Ultimate.

    I have used every port in the computer. I have tried unplugging everything to leave all USB power to the Kinect and still fails...

    The big enigma resides in that it seems to be power related (the Camera device blinks on and off endlessly in Device Mangager and Shape Game states that Kinect is attached to PC, but AC power missing)

    But just yesterday I bought a new Kinect and out of the box behaves just like the old one... What are the odds of having two faulty power sources?

    I'm thinking about putting a voltage checker in my outlets just to be safe...

    I just read: 50K downloads and it seems I'm the only one having such strange issues!

    It's been almost a week now and no solution...

    --------------------

    I'm here 'cause I need help

    Luigi


    LM
    Monday, November 14, 2011 2:01 PM
  • Hi,

     

    I also have a 2006 Mac Pro and have the exact same issue, plus when i run the SkeletalViewer Sample from Kinect SDK, the application starts, shows that kinect is with status "NotPowererd" and after a moment gives  a System.Runtime.InteropServices.COMException, the device does not recognize the command. (Exception from HRESULT: 0x80070016)

     

    Yesterday i made a post in the forum about the problem

    http://social.msdn.microsoft.com/Forums/en-US/kinectsdk/thread/f16e3ee3-f053-4deb-8ed0-5722a030b06c

    Monday, November 14, 2011 2:24 PM
  • It's good to know I'm not alone.

    It's a little bit of a coincidence that you're on a Mac as well, as Eddy mentioned in this thread

    http://social.msdn.microsoft.com/Forums/en-US/kinectsdk/thread/1edc452e-2f86-4426-97d5-2161ba932e69

    something about the USB Hub generally being detected as an Enhanced Controller, well in my case it lists as Generic USB Hub but in the Advanced tab inside the properties it shows that no devices are actually consuming power, and I know this is the hub Kinect is attaching to, because I see the devices in the Power tab of the same Hub: I see the camera, the audio and a Composite device.

    I have two different Windows 7 Ultimate on two separate disks and two different self-powered Kinects also.

    All possible configurations fail, in all USB ports.

    Impossible to get it to work?

    I also spent the last hour trying to manual install as somebody suggested in another thread.

    The camera stutters on and off endlessly in Device Manager and none of the SDK examples work.

    Help us Kinect Gods!!!

    L


    LM
    Monday, November 14, 2011 3:33 PM
  • Thanks for reporting this. We will investigate this further on our side.
    Monday, November 14, 2011 6:36 PM
  • I would uninstall kinect from device manager have you tryed that yet? Then uninstall kinect refresh sdk 1 and uninstall refresh beta sdk2 also.

    Remember when you reinstall the second sdk or first one for the first time when you plug in  kinect device in windows 7 try and skip getting drivers from windows update as it installs open ni drivers for some reason and not the correct ones which are located locally on your computer.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt.
    • Edited by The Thinker Tuesday, November 15, 2011 2:17 PM
    Tuesday, November 15, 2011 2:17 PM
  • Hello Mr. Thinker!

     

    The solution you suggest worked out once for me. The strange thing is that I have a fresh Windows install on another disk. I have also tried your suggestion on this *new* Windows just in case but it doesn't help at all.

    Once again the problem is that the Camera device is constantly mounting/unmounting.

    I have pointed out that the strange thing is that when I inspect the USB hub that all Kinect elements attach to, they show up in the Power tab but then in the Advanced tab there are actually 0 devices consuming energy.

    Bruno AC Pires is in a (older than mine) MacPro and has the exact same issue. Maybe it has to do with the way Macs handle USB ports, but then why was it working fine and then out of the blue stopped working?

    And to get things even stranger... Yesterday night I re-installed OpenNI drivers in the old copy of Windows just to test the second Kinect I bought thinking all this was a power issue. It works just as fine as the other with OpenNI drivers. Both Kinects fail to correctly mount all devices both in the Windows that has had OpenNI installed and the fresh one.

    This reminds me of the Win 95 days where installing a SCSI drive was a little bit less daunting than a trip to the moon!

    This is proving to be as difficult as achieving light speed!

    This is becoming much more than installing a device, it is turning into a quest!!!

    Cheers to all, and all suggestions welcome!

     

    LM


    LM
    Tuesday, November 15, 2011 3:25 PM
  • did you try everything from this older thread you had? Also, try making sure no other usb devices on plugged into the same usb hub which would be the front usb jacks or back if your using a desktop and back usually if using a laptop (i got 64-bit working from my laptop):

    http://social.msdn.microsoft.com/Forums/en-US/kinectsdk/thread/1edc452e-2f86-4426-97d5-2161ba932e69

    BTW, definitely make sure no OPEN NI drivers are installed because they might conflict with the kinect ones causing the kinect to malfunction. You might want to even test the usb ports (they can go bad) for correct voltage maybe with a voltage detector.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt.
    Tuesday, November 15, 2011 3:54 PM
  • OK So today I sat at a friend's computer, he has Windows 7 Home Premium 32-bit. Other than the 32-bit version not installing, once we installed the 64-bit version everything was working wonderfully, I brought in the two Kinects that just don't work at my place, and over there everything worked pretty much as expected. So I return home, uninstall the drivers once again, reinstall and oh surprise! it is working again! I can see skeletal tracking has improved right away, everything runs smoothly, I even compile the samples from the SDK... So the compiled version of Skeletal Tracker tells me that I may add another Kinect... And greedy me, I thought, what the heck, let's try two Kinects at the same time! And from there, back to the original puzzle, both Kinects fail to mount the Camera which just flickers in an endless cycle...

    I really hope someone can crack this one!

    Good nite to all!

    L


    LM
    Wednesday, November 16, 2011 5:06 AM
  • Try plugging one into front port and other into the back ports on the computer because i strangly remember someone posting before that they could use their first kinect but not the second one. Also, the kinects suck power thats why you shouldn't  have anything at all except maybe a usb flash drive in the front or back ports the computer is plugged into because of this.
    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt.
    Wednesday, November 16, 2011 1:32 PM
  • That's exactly how I set it up when one was working.

    I have tried front, back, only Kinect plugged in, etc.

    NOTHING WORKS!

     


    LM
    Wednesday, November 16, 2011 2:24 PM
  • Yeah maybe they messed up power i would check for certain that you dont have power loss so it does work now but only with one kinect? I would say power and to also check your incoming power from adapater (the new macs have that piece that attaches like a magnet and you need measure power coming from their).

    Using benchmarking software is a good idea too because you can monitor components plugged into your computer and see how much juice they are sucking let me look for one and i will pass it on.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt.

    • Edited by The Thinker Wednesday, November 16, 2011 2:56 PM
    Wednesday, November 16, 2011 2:55 PM
  • I feel the same complete nightmare.

    I have adapted my Kinect for XBOX 360 to be used in windows and apart from the SDK and and toolkit nothing works.

    I keep getting errors like "OpenNI.dll is not installed on your system" and "MSVCR110D.dll is not installed on your system.

    I have installed Micorsoft SDK 1.8 and all the versions of openNI and Microsoft Visual C++ 2005, 2008, 2010, 12

    Windows 8.1 Pro doesn't seem to like MSVCR110D.dll.

    Microsoft, please do something to clean this mess. I have read many forums and saw many frustrated people over such a promising technology.

    The different  programs use so many different drivers. If you have for instance an updated version of Microsoft Visual C++ 2010, that doesn't instal MSVCR110D.dl as a result most third party programs no longer work.

    I have converted my Kinect on the weekend and three days after I am very disappointed with this mess.

    Is there anyone driving this ship?

    I guess all this problems will lead Kinect for windows to absolute failure.

    Maybe none of this is your fault. It is not your fault if other people are also developing drivers for kinect,  and that other people are developing programs based on these drivers, but since the community is doing such a mess, please develop some free programs, Like Windows face login, windows pointer and game free view mode, to gather the public enthusiasm for this great product. All of the programs I have seen so far are a driver nightmare.


    Wednesday, March 12, 2014 8:48 PM
  • Sounds like you are having USB2 available resource or power issues. Do you have the USB plugged into the computer and wall power? What color is the LED on the front? The Kinect requires it own dedicated USB2 Host controller for data throughput. It cannot share the USB ports with other devices.

    You can determine this by checking the Device Manager and sort the list by connection(view menu > Devices by connection. You have to drill into the list under ACPI. When you get to the "USB Host Controller" sections, be sure you only see the Kinect listed under that controller.

    Kinect for Windows SDK and OpenNI are separate SDK's and do not work together. There are other threads that discuss this. If your project is using OpenNI, then be sure to not install Kinect for Windows SDK since their drivers conflict with the official Microsoft drivers for the sensor.

    If you have removed all previous SDK's and drivers from your syste,. and want to use the officially supported sensor and SDK by Microsoft, then install Kinect for Windows SDK and Toolkit only. There are several samples provided by the toolkit to get you up and running.


    Carmine Sirignano - MSFT


    Wednesday, March 12, 2014 10:21 PM