none
Encoding problems in VS Express 2013

    Question

  • Hi guys,

    I'm used to writing codes in the UTF-8 encoding but a few weeks ago,
    I accidentally changed settings via keyboard shortcuts (I didn't mean to change the settings).
    Since then, every time I try to open a C++ file inside a solution, I am being asked on which encoding settings to do.

    How can I change that I won't be needed to be asked every time I need to open a file ?

    (P.S I wanted to put a picture of the situation but my accounts isn't verified ... )

    Thanks for help !

    Saturday, June 18, 2016 8:19 AM

Answers

  • Hi Joel_RU,

    >> I accidentally changed settings via keyboard shortcuts

    Could you please explain how do you change the settings? And do you change the settings for the C++ file or Visual Studio?

    If you changed the Visual Studio settings, please reset the settings through Tools -> Import and Export settings -> Reset all settings.

    If you changed the C++ file settings, please try change the file encoding settings with following steps.

    1. Open the file in Visual Studio.
    2. Click the menu File -> Advanced Save Options to choose the encoding settings.
    3. Click the Ok button.
    4. Save current opened file.

    And please also set the default editor for your C++ file through right-click the file to choose Open with. The default editor for .cpp file should be C++ Source Code Editor. Please set it as default editor.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 21, 2016 6:14 AM
    Moderator

All replies

  • Hi Joel_RU,

    thanks for posting here.

    This forum is about c++ development. For your case which is about vs settings, I will move your case to vs general forum for better help.

    Best Regards,

    Sera Yu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Monday, June 20, 2016 7:17 AM
  • Hi Joel_RU,

    >> I accidentally changed settings via keyboard shortcuts

    Could you please explain how do you change the settings? And do you change the settings for the C++ file or Visual Studio?

    If you changed the Visual Studio settings, please reset the settings through Tools -> Import and Export settings -> Reset all settings.

    If you changed the C++ file settings, please try change the file encoding settings with following steps.

    1. Open the file in Visual Studio.
    2. Click the menu File -> Advanced Save Options to choose the encoding settings.
    3. Click the Ok button.
    4. Save current opened file.

    And please also set the default editor for your C++ file through right-click the file to choose Open with. The default editor for .cpp file should be C++ Source Code Editor. Please set it as default editor.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 21, 2016 6:14 AM
    Moderator
  • Thank you!
    Monday, July 25, 2016 3:37 PM
  • Hi Weiwei Cai,

    about the settings I accidentally changed - I guess I clicked something and the screenshot you provided was open and the default "code editor" was marked (with encoding) so that was the problem basically!
    I changed my "code editor" to the c++ one without the encoding option and my problem was solved!

    Thank you very much! 

    Monday, July 25, 2016 3:41 PM