locked
Using Crystal Reports with ASP.NET RRS feed

  • Question

  • User246057125 posted

    I have never used Crystal Reports with ASP.NET. Does it work in a same manner as with a desktop application?

    While publishing a website, what things to keep in mind to make Crystal Reports work on a web page?

    Saturday, September 24, 2011 11:36 PM

Answers

  • User1196771204 posted

    hi rpk2006,

    You can find the module on the Crystal Report website and you need to have them installed on your system. There are several other requirements to run Crystal Report:

    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it withasphostcentral.com

    Please mark this response as an "answer" if it helps you. Thanks heaps!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, September 25, 2011 11:32 PM

All replies

  • User705563967 posted

    you should create and install merge module for crystal report on deployment server before publishing otherwise no difference b/w desktop and web.

    Sunday, September 25, 2011 3:02 AM
  • User246057125 posted

    Where can I find this module?

    Sunday, September 25, 2011 4:05 AM
  • User1196771204 posted

    hi rpk2006,

    You can find the module on the Crystal Report website and you need to have them installed on your system. There are several other requirements to run Crystal Report:

    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it withasphostcentral.com

    Please mark this response as an "answer" if it helps you. Thanks heaps!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, September 25, 2011 11:32 PM