locked
User Policy function disabled for service account RRS feed

  • Question

  • In order to add users to a permission policy I followed the instruction below,

    1. Verify that you have the following administrative credentials:

    I am currently running on service account which I used to create this SPS 2010 server farm. This account is in Farm administrators group.

    2. On the Central Administration Web site, in the Application Management section, click Manage web applications.

    3. Click to highlight the line for the Web application "SharePoint Central Administration v4" whose permission policy I want to manage.

    4. In the Policy group of the ribbon, click User Policy.

    In fact the User Policy link is disabled. If I select Web Application on port 80, User Policy link is enabled.

    Anyone knows why?

    Thanks in advance,

    Peter

     

     

    Thursday, November 11, 2010 1:04 PM

Answers

  • Hi,

     

    It is by design.  SharePoint don’t allow configuring these settings for central admin application.

    We also can get same behaviors in SharePoint 2007.

     

    Hope this helps

     

    Thanks!

    Stanfford


    Everything will be fine.
    • Marked as answer by peterxw Tuesday, November 16, 2010 1:04 PM
    Monday, November 15, 2010 7:23 AM

All replies

  • Hi

    Try using the Farm administrator's account itself.  Also check to see if the FArm admin account has full control over the web apps.

    This definately looks like a permissions problem.

    Regards

    Nigel

    Thursday, November 11, 2010 2:24 PM
  • Nigel,

    The account I use to run Central Administration Tool is the service account. It is the farm administrator account. The SharePoint timer server running under this account as well.

    It looks like I am missing something here.

    Thanks,

    Peter  

     

    Thursday, November 11, 2010 3:55 PM
  • I have found the same issue on a separate SPS 2010 server farm as well. Anyone have the same experience?

    I am sure this is the permission issue, but not sure what I am missing

    Thanks,

    Peter

    Friday, November 12, 2010 1:03 PM
  • Hi,

     

    It is by design.  SharePoint don’t allow configuring these settings for central admin application.

    We also can get same behaviors in SharePoint 2007.

     

    Hope this helps

     

    Thanks!

    Stanfford


    Everything will be fine.
    • Marked as answer by peterxw Tuesday, November 16, 2010 1:04 PM
    Monday, November 15, 2010 7:23 AM