locked
SharePoint Designer 2013 cannot access workflows in Office 365 Site RRS feed

  • Question

  • I have an Office 365 SharePoint site with a number of workflows that I have created on my machine with SPD 2013. After a number of weeks I was unable to access the workflows from my machine through SPD (while still being able to access pages, site assets etc.), getting the following error: (Am restricted from submitting images)

    "Server-side activities have been updated. You need to restart SharePoint Designer to use the updated version of activities"

    Restarting SPD doesn't help, after clicking OK I get the "SharePoint Designer cannot display the item" screen, prompting me to refresh. 

    When I do refresh, I get the following:

    "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature"

    This is happening on my machine, Windows 7 64 Bit, SPD 2013 64 Bit, but on a colleague's machine, Win 7 64 Bit, SPD 2013 64 Bit I can access the workflows. 

    I get the same error if I try to create a new Workflow on my machine but I can create it on my colleague's machine.

    I downloaded SPD 2013 on a 32 bit laptop I have access to, in which I can create a workflow. One existing workflow can be accessed, updated etc. with no issue, one opens to a prompt to "Insert a stage" and one tells me that it "Failed to load the workflow definition for the workflow", then the "SharePoint Designer cannot display the item" screen. All of these workflows can be accessed from my colleague's machine.

    Here are the actions that I have taken to date on my own machine:

    • Cleared the caches multiple times
    • Checked for updates
    • Installed .Net Framework 4.5
    • Re-installed .Net Framework 4.0 (which contains 3.0)
    • Uninstalled and re-installed SPD 2013 

    Due to issues with a workflow on the site I am in contact with MS Support who are aware of this issue, they sent me a link to a hot fix that was already installed but they have no concrete idea of what might be going on.

    I was convinced that it was an issue on my machine, but I don't know what the issues that I have seen on the 32 bit SPD on the new laptop mean.

    I have been searching the internet for a fix with no success, I would appreciate any help.

    Thanks

    Mick


    Thursday, October 31, 2013 11:30 AM

Answers

All replies

  • Hi,

    According to your post, my understanding is that SharePoint Designer 2013 cannot access workflows in Office 365 Site.

    There was an issue recently when a service release was implemented that incremented the version number in the HTML header on some SharePoint online sites to '16' when SPD was expecting '15'. 

    I suggest to install internet explore 10 and install a patch for IE10. Then test with "open with windows explore" then opened in SPD from sharepoint online.

    In addition, I suggest that in SPD go to Account > Switch Account and type in the credentials of the site you are trying to open (it defaults to your Microsoft Login).

    If the issue persists, to troubleshoot this issue, you can uninstall all versions of SharePoint Designer on workstation, clear cache and then reinstalling the latest SharePoint Designer. For the detailed information, you can refer to the article: http://support.microsoft.com/kb/2794961

    Here are two similar threads for you to take a look at:

    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/15fd1436-3166-4e43-8b22-cdb480091548/cant-open-sharepoint-online-site-in-sharepoint-designer-2013

    http://community.office365.com/en-us/forums/154/t/149314.aspx?PageIndex=2

    By the way, you can also post the question in Office 365 forum and more experts will assist you.
    Office 365 forums :http://community.office365.com/en-us/forums/default.aspx

    More information:

    SharePoint Designer 2013: Server-side activities have been updated: http://www.andreasthumfart.com/2013/08/sharepoint-designer-2013-server-side-activities-have-been-updated/

    Best Regards,

    Linda Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    • Marked as answer by JasonGuo Thursday, November 7, 2013 11:06 AM
    Friday, November 1, 2013 6:14 AM
  • We have exactly same issue Mike on on premise and some time after clearing cache it works and some times this "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature" error comes back and then we can not do anything until it opens up again. 

    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    Friday, May 16, 2014 8:13 PM
  • Hi Mick,

    Today when I opened my SPD2013 workflows in 32 bit SPD2013 then suddenly it is showing blank and only with Insert Stage

    So when I again tried to open it in 64 bit SPD2013 but still it is showing me blank.

    But in the site workflow functionality is up and running, I guess this is working because of last time when I deployed the WFs.

    Do you have any suggestion or help on this to get back or download my workflows in designer as like earlier , otherwise I have no option to re-create these workflows once again.

    Thanks,

    Ravi

    Friday, August 26, 2016 12:23 PM
  • Hello


    I resolved this issue of the blank workflows with the install of the Service Pack 1 pour Microsoft SharePoint Designer 2013 (KB2817441) Édition 32 bits

    https://www.microsoft.com/fr-fr/download/details.aspx?id=42015

    I had Sharepoint Designer 2013 installed when I launched  the exe, it doesn't install there were a message like the version is not ok for this install...

    So the command line must be used :

    In Run Type  this command :C:\Path to the file\spdsp2013-kb2817441-fullfile-x86-en-us.exe  PACKAGE.BYPASS.DETECTION.CHECK=1

     And The content of the workflow appears, and the button "Open in access"  in the bar of the list  too   .

    Magthemag


    • Edited by magthemag Friday, August 18, 2017 1:53 PM
    • Proposed as answer by steph12345678 Monday, June 3, 2019 2:06 PM
    Friday, August 18, 2017 1:50 PM
  • Hi Magthemag,

    I tried to install the same patch which installed well however i still cannot see the workflow in SPD 2013. 

    Do you have any further information?

    Thanks 

    Bhushan 

    Tuesday, June 26, 2018 1:45 PM
  • Magthemag,

    It is 2019 July now and I just sign-in to say thank you for your information. 

    One of our teammate use SPD 2013 64 bit to create a SP2013 workflow. However when other teammates open the workflow it is empty. Later we patched the SPD with your method and problem solved.

    It is so sad that Microsoft never updated their instruction or patches after some many years.

    Microsoft really pay no attention to on-premise product support. Not sure why they are now selling SP2019 on-premise.

    Tuesday, July 30, 2019 4:07 AM