locked
The "exists" function only accepts a scalar value, but its argument evaluates to which is not a scalar value RRS feed

  • Question

  • User1217208235 posted

    Hello everyone,

    Recently I was working Publish my project from my local machine, to a remote hosting server with WebPublishing.

    I am trying to publish WebFiles and Database.

    this is what I did:

    1) In project properties > Package/publish web > (select) Include all databases configured in Package/PublishSQL tab

    2) In project properties > Package/publish SQL >  (clicked on) Import from web.config > eventually it added a Database entry.

    3) Than in same tab I entered Source database information

    4) Destination Database information "Connection string for destination database:" is blank since I don't have a publicly oppen MSSQL server connection to my Database. Destination is behind the firewall and that is why I have configured destinations IIS websites publishing settings (located under: rightclick website > Deploy > Configure web deploy publishing) to have connection to that destination SQL server...

    5) Destinations IIS website deploy configurations accepts destination SQL server, connection is ok there... all I need is to push a database through it along with my WebPublish...

    So I was hoping it would work, but does not seem to do so...

    As a result when I am trying to publish I am getting this error here: 

    The "exists" function only accepts a scalar value, but its argument "%(_DatabasesToPackage.SourcePath)" evaluates to "[Database connection string]" which is not a scalar value. 0 0  [local wbesite host name]

    And so I am not sure what where and why this error would appread. Could someone please have any suggestions what can cause this, and what does this "scalar value" has to do with web Publishing???

    Got really stuck on this one, but it would REALLY help along with the project!

    Kind regards,

    Dmitrij

    Monday, September 16, 2013 4:46 AM

All replies

  • User1442230747 posted

    Hi,

    Please put the destination connection string(although it is not accessible) and then create the package. This should resolve the issue

     

    Regards

    Ravindra

    Thursday, September 26, 2013 7:36 PM