locked
Azure VM Communication link failure on ODBC RRS feed

  • Question

  • I've got an Azure VM that I am trying to create an ODBC connection on using ODBC administrator. When trying to connect however it errors with

    [SAP AG][LIBODBCHDB32 DLL][HDBODBC32]Communication link failure;- 10709 
    Connection failed (RTE:[89006]System call 'connect' failed, rc=10060:A 
    connection attempt failed because the connected party did not properly 
    respond after a period of time, or estab
    

    I have tried disabling the firewall to see if that works to no avail. Any help or ideas would be much appreciated. Thanks!

    Friday, February 9, 2018 2:53 PM

Answers

  • Thanks for the help. But it turns out the reason it's not working is due to my corporate network structure. Apologies.
    Thursday, February 15, 2018 9:26 AM

All replies

  • For a deeper analysis of this issue, I would suggest you open a support ticket as described in this link How to create an Azure support request. The ticket will help you work closely with the support for speedy resolution.

    ===================================================================

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Friday, February 9, 2018 7:49 PM
  • Could you also share some more information? Such as what documents you are following. That way we try and repro the issue as well.
    Friday, February 9, 2018 10:06 PM
  • Sure, I originally had this ODBC connection working fine on a previous Azure VM. But we needed to migrate to a different domain. So a new VM was created copying the contents from the disk of the old VM. So everything setting was kept across. But now the ODBC connection does not want to work. I've tried opening ports or turning the firewall off but I still get the communication link failure. I reinstalled the ODBC drivers, but nothing. It seems the error isn't specific enough to be able to find a straighforward fix. But I'm not sure what else to try.
    Monday, February 12, 2018 9:37 AM
  • Thanks for all that Bradley. 

    In addition to opening ports did you add the correct NSG rules for those ports? 

    Monday, February 12, 2018 6:57 PM
  • I created an inbound rule with port 30015, and left all the other settings as is. So pretty much all are 'Any'. I did this using windows firewall with advanced security. What part are the NSG rules?
    Wednesday, February 14, 2018 9:51 AM
  • Network Security Groups can be added and modified from the Azure Portal. 

    Select the VM -> Networking -> Add inbound port rule

    Select Advanced

    Add the rule to allow traffic to the port you need

    Wednesday, February 14, 2018 6:05 PM
  • Thanks for the help. But it turns out the reason it's not working is due to my corporate network structure. Apologies.
    Thursday, February 15, 2018 9:26 AM
  • No worries Bradley. Happy to hear you were able to determine the reason :) 
    Thursday, February 15, 2018 4:23 PM