none
.NET 40 Redistib install error "failed with 0x240006" searched the forums RRS feed

Answers

  • Please follow these steps exactly.

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by Alexander Sun Thursday, January 26, 2012 5:36 AM
    • Marked as answer by Alexander Sun Wednesday, February 8, 2012 7:57 AM
    Tuesday, January 24, 2012 8:11 PM

All replies

  • Please follow these steps exactly.

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    • Proposed as answer by Alexander Sun Thursday, January 26, 2012 5:36 AM
    • Marked as answer by Alexander Sun Wednesday, February 8, 2012 7:57 AM
    Tuesday, January 24, 2012 8:11 PM
  • Your fix worked! I can't thank you enough, been trying to solve this problem so I can play Terraria for HOURS AND HOURS. Finally something worked, seriously thank you so much!
    Sunday, December 9, 2012 1:58 AM
  • Hello pvdg42,

    I was connected with you in other issue with the same problema.

    I proveed all solutions from the links and the solution showed here but all of them don´t work. Every time stop the installation and finish as fatal error.

    I proved the command and the new administrator user but didn´t work.

    Could you know other think that I could prove? I´m an user and know the basic and check thinks step by step.

    Thank you very much for your support. Best regard. mapag123

    Tuesday, November 25, 2014 3:27 AM