none
Books Online July 2006 issue RRS feed

  • Question

  • The SQL Server Books Online was working installed on my workstation fine until this morning.  Now when I open it up it does not show me T-SQL reference with all the commands and functions.  Yesterday I was on the MSDN website using the Books Online.  Could some pointers in the program been corrupted?  I have uninstalled and reinstalled Books Online to no avail.

    Please help.

    Thanks,

    Fred

    Thursday, October 26, 2006 1:51 PM

Answers

  • Hi Fred,

    Okay, this sounds like maybe a filter was accidently set that is limiting the returned topics.  At the top of the Contents tab, there's a "Filtered By"  drop down box.  Make sure the filter is set to either 'unfiltered' or 'SQL Server 2005', or 'SQL Server Database Engine'. 

    That should resolve the problem, but if it doesn't let me know.

    Gail

    Thursday, October 26, 2006 9:05 PM
    Moderator

All replies

  • Hi Fred,

    When you open Books Online on your local machine, do you see a Contents tab (typically located on the left-hand side of the page)?  If no, click the Contents option on the top tool bar.  This should reopen the Contents tab that has been closed or hidden.

    2. If that doesn't resolve your problem, can you please provide more information. For example, can you find T-SQL Reference topics by using the Index or Search tabs? 

    Regards,

    Gail

    Thursday, October 26, 2006 7:00 PM
    Moderator
  • Hi Gail,

    Yes, the Contents tab is there.  When I expand "SQL Server 2005 Books Online" entry  in the Contents tab and then expand "SQL Server Language Reference" it shows only "Transact-SQL Reference".  It used to show more.  Then when I expand "Transact-SQL Reference" it only shows "System Tables (Transact-SQL)".  It used to list all the statements and functions.

    Thanks,

    Fred

    Thursday, October 26, 2006 7:19 PM
  • Hi Fred,

    Okay, this sounds like maybe a filter was accidently set that is limiting the returned topics.  At the top of the Contents tab, there's a "Filtered By"  drop down box.  Make sure the filter is set to either 'unfiltered' or 'SQL Server 2005', or 'SQL Server Database Engine'. 

    That should resolve the problem, but if it doesn't let me know.

    Gail

    Thursday, October 26, 2006 9:05 PM
    Moderator
  • Hi Gail,

    Thanks, that fixed the problem. 

    Fred

    Friday, October 27, 2006 12:24 PM