none
EDI 856 to xml mapping in biztalk 2009 RRS feed

  • Question

  • I am working on EDI 856 to XML map. 

    The structure of EDI 856 file is like one shipment,multiple orders with each order with multiple items.

    HL*1**S
    TD1
    TD5
    TD3
    REF*BM
    REF*VR
    DTM*011
    DTM*068
    DTM*056
    DTM*017
    N1*SF
    N1*VN
    V1*
    HL*2*1*O
    PRF*
    HL*3*2*I
    LIN*1*
    SN1**600*PC
    HL*4*2*I
    LIN*3*
    SN1**624*PC
    HL*5*2*I
    LIN*8*
    SN1**442*PC
    HL*6*5*O
    PRF*
    HL*7*6*I
    LIN*1
    SN1**600*PC

    The XML structure is like

    Shipment

    Order

    Item

    Order

    Item

    I am using customized schema for edi and directly linking source segments with the targets. The map is working fine for one order with multiple items in it. But it's throwing errors when there are multiple orders in one shipment.

    Can any one guide me on how to use xslt/scripting to solve this issue

    Friday, November 15, 2013 3:53 PM

Answers

  • Hi Amita

    The map is working fine for one order with multiple items in it. But it's throwing errors when there are multiple orders in one shipment.

    For this issue, I think the error message could give some hints why this happens. At the same time it's also  recommended to learn relevant issues about EDI 856 HL Looping in BizTalk 2009, I think it is available to troubleshoot this issue.

    Regards


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Pengzhen Song Wednesday, November 27, 2013 1:22 AM
    Monday, November 18, 2013 3:36 AM