locked
4.0.11 version control problem RRS feed

  • Question

  • User3492 posted

    After updating Xamarin Studio to 4.0.11 all solutions appear to be under version control - even though they are not.

    Therefore I am no longer able to update any solution (adding new files, renaming etc.) as all I get is error messages like: "'' is not a working copy".

    Thursday, August 1, 2013 8:45 AM

All replies

  • User17138 posted

    The same problem here! With and without SVN 1.6 and 1.7 versions...

    Thursday, August 1, 2013 12:45 PM
  • User3492 posted

    Disabling the version control add-ins in 'Add-In Manager' fixes the problem.

    Thursday, August 1, 2013 12:50 PM
  • User28 posted

    A number of VCS issues have been fixed in the next release, please file a bug if this is still an issue.

    Monday, August 5, 2013 10:43 PM
  • User70 posted

    Michael,

    This is an absolute nightmare I'm afraid to say. I know you are working hard on XS but I just spent the last two hours trying to get a web reference added and tried every channel and finally had to disable the add-in per the above.

    PLEASE push out a fix in Alpha, Beta, wherever but please do so immediately as this is a show stopper.

    Thank you! Just frustrated, XS has really been getting in the way of productivity lately.

    Tuesday, August 6, 2013 11:01 PM
  • User9642 posted

    After upgrading to 4.0.11 all registered repositories in XS have disappeared. After inserting them again, I checked out a solution to a blank directiory (SVN), made a change and wanted to commit again, but looking on "Review solution changes" tells me that there are no files have local modifications...

    We'll have to go back to 4.0.10.

    Wednesday, August 7, 2013 9:53 AM
  • User3492 posted

    XS 4.0.12 behaves just like 4.0.11: all solutions appear to be under version control - even though they are not.

    Had to disable the version control add-ins again.

    Friday, August 9, 2013 6:27 AM