locked
VS 2013 Web Deployment Omits files from the deployment package RRS feed

  • Question

  • User1787608197 posted

    When I Publish my web application, the deployment .zip file omits at least one style sheet.

    On my development machine, in debug, I get the following web display:

    (well  - I cannot put a picture  into this form.)  ----  anyhow, the control that references colorpicker.css displays correctly.

    On my test machine following deployment - that same control shows a small red x indicating a problem,   Looking in the virtual directory, colorpicker.css is absent.  It is also absent from the .zip file.   If I change the copy attribute of colorpicker.css to copy always, it shows up in the virtual directory in .bin.styles, but is not accessed by the web application.


    HOw can I repair this problem?

    
    

    Thursday, April 21, 2016 1:46 PM

Answers

  • User-166373564 posted

    Hi donpgolden,

    From your description above, I'd like to suggest you to check the following items:

    To publish a Web application project

    1. On the Build menu, click the Publish ProjectName option.
    2. In the Publish Web dialog box, click the ellipsis button (…) to browse to the location to which you want to publish the Web application project.
    3. Select either the Replace matching files with local copies check box or the Delete all existing files prior to publish check box.
    4. Select how you want to copy the Web application project files to the new location: Only files needed to run this application, All project files, or All files in the source project folder. Also, you can include files from the App_Data folder by selecting the related check box.
    5. Click OK to publish your Web application project.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, May 4, 2016 2:14 AM

All replies

  • User-286291038 posted

    Hi donpgolden,

    What is the location from where you are accessing that css file in your html pages? Also, could you check if the css file has been included in the project before the deployment package is create?

    Thursday, April 21, 2016 2:12 PM
  • User1787608197 posted

    <link rel="Stylesheet" href=".\Styles\ColorPicker.css" type="text/css" /></head>

    On the development machine - the code finds the style sheet, but on the deployment test machine, the .css file is not present.

    I do not know how to do the second step of your suggestion.

    Thursday, April 21, 2016 10:31 PM
  • User-166373564 posted

    Hi donpgolden,

    From your description above, I'd like to suggest you to check the following items:

    To publish a Web application project

    1. On the Build menu, click the Publish ProjectName option.
    2. In the Publish Web dialog box, click the ellipsis button (…) to browse to the location to which you want to publish the Web application project.
    3. Select either the Replace matching files with local copies check box or the Delete all existing files prior to publish check box.
    4. Select how you want to copy the Web application project files to the new location: Only files needed to run this application, All project files, or All files in the source project folder. Also, you can include files from the App_Data folder by selecting the related check box.
    5. Click OK to publish your Web application project.

    Have a good day.

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, May 4, 2016 2:14 AM