none
Kinect SDK 1.0 drivers load for XBox Kinect but not Windows Kinect RRS feed

  • Question

  • I just received my new Windows Kinect and am unable to successfully load the new Kinect SDK 1.0 drivers when I plug in the Kinect for Windows device.

    I uninstalled my earlier Beta SDK, rebooted, and then installed the new 1.0 SDK. When I plug in my Kinect for Windows to a USB port, I the drivers continuously attempt to load and then fail. The device manager keeps beeping at regular intervals as it attempt and fails to load the drivers (its in an infinite loop of loading and failing).  And, yes, the power is plugged in.

    The device manager shows only 1 successfully loaded driver (Microsoft Kinect Camera) and 2 unsucessfully loaded "Unknown devices" entries. The odd thing is that the device manager does not give up after failing and keeps trying to resolve the 2 unkown devices (resulting in alot of system device load and load failure system sounds as well as repeated refreshing of the device manager window).

    I have tried numerous re-installs of the SDK with no success. On one occassion, I did see both the Camera and Device drivers present under the Microsoft Kinect device group, but none of the sample apps would run properly.  The Kinect explorer could see the Kinect, but said it was not powered. Other demo apps said it was either not plugged in, or was unpowered. This is misleading because it is definately plugged in and I can see the green light blinking.

    Here is the weird thing: when swap my original Xbox Kinect for the Windows Kinect (using the same connected powered USB cord and the same USB port) my old Kinect works perfectly with the new 1.0 SDK. The skeleton viewer demo works perfectly.  The Kinect Explorer, however does not recoginize the old Xbox Kinect.

    Any ideas? I am very very very frusterated.

    Tuesday, February 14, 2012 4:00 AM

Answers

All replies

  • You may have already tried this, but it might not hurt to try to clean things up one last time:

    Unplug all Kinects.
    Uninstall all of the "Kinect" things in your Add/Remove Programs - notably, the SDK, the Runtime and the Driver should be gone.
    Reboot (probably not needed, but it can't hurt)
    Install v1.0 SDK.
    Reboot (probably not needed, but it can't hurt)
    Plug in a Kinect, wait for all the devices to show up (lots of green check marks in the USB/device dialog that pops up)

    Try KinectExplorer.

    If this doesn't work, I'll try to connect you with our setup folks, since it sounds like your machine is in a weird state.


    -Adam Smith [MSFT]

    Tuesday, February 14, 2012 7:28 AM
  • Thank you for your response.

    The steps you suggested are exactly what I did on all my attempts to fix this problem (including all the rebooting). To be absolutely sure, I just went through the process one more time, and still had no success.

    I have also noticed that if I try moving the device to any other USB port than the one I first attempted to use, the device manager will immediately see it as an uknown device and not even try to load any drivers. This happens as well for the XBox Kinect. It is important to point out, however, that I use lots of USB devices, blue tooth keyboard dongles, mouse dongles, and I even connect my 30 inch Dell monitor with 4 USB ports to a single USB port on my computer; in all cases I can move all of these USB connections to any desired port and never have a hint of trouble.

    Although I have little knowlege of driver installation, I do know alot about softare developement, and it "feels" to me that the Kinect has somehow stubbornly binded itself to a single USB port which it has no intention fo reqlinquishing for a new one.

    On my last attempt, the only port that would even considered recongizing my Kinect was, the original one I used on the first install. 

    Perhaps you are right about the machine being in a weird state, but only for the Kinect. I have had not problems with any other device since I bought this machine over 1 year ago.  Bye the way, it is the mother of all Thinkpads, the w701ds with a NVida QUAD 2800 FM graphics card.

    Please help!


    Tuesday, February 14, 2012 8:51 AM
  • Hi Adam. I'm hoping that you will do as you suggested and connect me with the setup folks since I can't do any of my Kinect work until this problem is resolved...

    Thanks in advance.

    • Proposed as answer by Scriptnetics Wednesday, February 15, 2012 2:11 PM
    • Unproposed as answer by Scriptnetics Wednesday, February 15, 2012 2:11 PM
    Wednesday, February 15, 2012 2:47 AM
  • Just a thought - but I have discovered some devices do not play well with USB 3.0, maybe the Kinect?

    Your problems are similar to problems I've had with devices that support 2.0 only plugged into a 3.0

    • Edited by Scriptnetics Wednesday, February 15, 2012 2:14 PM
    Wednesday, February 15, 2012 2:12 PM
  • what is the make/model of your USB host controller?
    Wednesday, February 15, 2012 8:03 PM
  • also (with XBox Kinect plugged in), can you go to device manager / Microsoft Kinect and right-click on Microsoft Kinect Camera / Properties / Driver and post what the date and version are?
    Thursday, February 16, 2012 3:30 AM
  • I am having the exact same issues. And we need another four Kinects

    We brought these to be legal but at the moment we cant use them.

    Any solutions to this issue? - This is costing us money.

    /Paul

    Thursday, March 1, 2012 11:17 PM
  • Also sorry to hijack the post but my driver details with the Xbox Kinect plugged in are as follows

    Date -  9/01/2012

    Version - 1.0.0.514

    Any help appreciated as mentioned above we have a commercial project going live with this product.

    Thanks Paul

    Thursday, March 1, 2012 11:31 PM
  • Since you hijacked, what troubleshooting steps have you tried? Can you answer the questions posted throughout this thread?
    Friday, March 2, 2012 12:04 AM
  • So you have all the background Info

    I was running sdk beta 2, then switched to the openNI Drivers and now the kinect sdk is commercially viable I switched to v1.0.

    Machine

    Macbook pro i7 8gb ram running windows 7 boot-camped

    Kinect Driver Info

    Date -  9/01/2012

    Version - 1.0.0.514

    Host Controller

    IEEE 1394 Bus host controllers


    I have tried all the suggested fixes on this thread and others, like un-install reboot, install, reboot etc, but still no go. 

    Other notes

    When I plugin the Windows Kinect only the camera shows under the device manager, but when I plugin the xbox kinect the camera,audio and motor drivers appear. 

    Are there different drivers for the xBox and the Windows Kinect bundled in the sdk?

    Thanks for your help :)

    Friday, March 2, 2012 4:54 AM
  • Hi red010b37,

    Please try using a different USB 2.0 port.  IEEE 1394 is the Firewire standard name. Can you provide the specific USB controller name?  The Kinect for Windows device works over USB 2.0, and does have some compatibility problems with certain USB 3.0 controllers.  Also, please make sure to unplug your sensor and then uninstall any previous drivers, including the OpenNI drivers, prior to installing the V1.0 drivers.

    Hope that helps.

    Friday, March 2, 2012 8:51 AM
  • You must make sure nothing else is plugged into the usb ports but if it uses usb 3.0 ports some people have had driver problems with usb 3.0 but Im not for sure if that has be fixed. I wonder is their a website we can go to find out about bugs for kinect sdk v1? Or can someone post at minimum every fews month the major bugs being worked in thier forum so people can know about limitations/problems before coding (doesnt mean that limitation would be their in future)? I think this will help people a lot. It appears this is a repeat of a post a few months ago todd that you attemped to answer with a mac with windows on it let me search for that post because it was on beta 2.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda


    Friday, March 2, 2012 1:19 PM
  • I'm sorry for not responding sooner to your requests, but I have had some important deadlines to meet. To accomplish this and avoid the time it would take with all the back and forth that solving this problem would require, I simply restored my Lenovo Thinkpad to factory settings and this, of course, solved the problem. It was faster re-installing all my applications and data than trying find the problem and solve it through a  forum. Thanks for trying to help, and to other people who have had a similar issue, I regret that I can't help by providing a less drastic solution.

    Friday, March 2, 2012 11:25 PM
  • that's ok, glad you are up and running!
    Saturday, March 3, 2012 4:35 AM