locked
Error when running job that runs a Integration Service package RRS feed

  • Question

  • Dear Sirs,

    In my environment, I have installed SQL Server 2005 64 bit on Windows Server 2008 R2 Enterprise.

    I created a Integration Service package that runs successfully when run it manually, but when I create a job via the SQL Server Agent to run it (type "Sql Server Integration Services Package"), occurs the error message below:

    "This task does not support native Win64 environment. Please run the package in 32-bit WOW environment instead."

    In this package there is an Integration Service object "Execute DTS 2000 Package Task."

    Why this error is occurring? What is the solution? Can anyone help me ?

    Thanks in advance,

    Jose Luiz
    Monday, May 2, 2011 4:01 PM

Answers

  • I managed to solve my problem by scheduling the job to run the package IS, using the job type  "Operating System (CmdExec)" and running the program "dtexec.exe" 32-bit. But to succeed, I could not use the "/FILE" but the "/DTS" since the "/FILE" occurred the following error:

    "Failed to decrypt protected XML node" DTS: Password "with error 0x8009000B" Key not valid for use in specified state.. "You May Not Be Authorized to access this information. This error Occurs When there is a cryptographic error. Verify That the correct key is available. "

    Then I replaced the parameter "/FILE" with "/DTS" and the command was as below and ran successfully:

    "C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\dtexec.exe" /DTS "\MSDB\package_name" /SERVER server_name /MAXCONCURRENT "-1" /CHECKPOINT OFF /REPORTING EWCDI

    Thanks again...

    Jose Luiz
    • Proposed as answer by Peja Tao Wednesday, May 4, 2011 8:34 AM
    • Marked as answer by Alex Feng (SQL) Wednesday, May 11, 2011 2:22 AM
    Tuesday, May 3, 2011 7:14 PM

All replies

  • Jose,

    In the job step for the SSIS package, go to the command line tab and choose to edit the command, add /X86 to the end of the command as an option. This will force the dtexec utility to run in 32-bit mode.

     

    Source: http://msdn.microsoft.com/en-us/library/ms162810.aspx

     

    Hope this helps,
    Sean

    Monday, May 2, 2011 7:57 PM
    Answerer
  • I managed to solve my problem by scheduling the job to run the package IS, using the job type  "Operating System (CmdExec)" and running the program "dtexec.exe" 32-bit. But to succeed, I could not use the "/FILE" but the "/DTS" since the "/FILE" occurred the following error:

    "Failed to decrypt protected XML node" DTS: Password "with error 0x8009000B" Key not valid for use in specified state.. "You May Not Be Authorized to access this information. This error Occurs When there is a cryptographic error. Verify That the correct key is available. "

    Then I replaced the parameter "/FILE" with "/DTS" and the command was as below and ran successfully:

    "C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\dtexec.exe" /DTS "\MSDB\package_name" /SERVER server_name /MAXCONCURRENT "-1" /CHECKPOINT OFF /REPORTING EWCDI

    Thanks again...

    Jose Luiz
    • Proposed as answer by Peja Tao Wednesday, May 4, 2011 8:34 AM
    • Marked as answer by Alex Feng (SQL) Wednesday, May 11, 2011 2:22 AM
    Tuesday, May 3, 2011 7:14 PM
  • Hi Jose Luiz,
    Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.

    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 4, 2011 8:35 AM