none
I randomly touch the mouse and key board and find a problem that one of the tool becomes not a member of my project RRS feed

  • Question

  • Dear Sir,

    I randomly touch the mouse and key board and find a problem that one of the tool becomes not a member of my project as per the attached two photos.

    I checked every thing and find there is no mistakes (that before random touches, there was no any problem), please help.

    When I tried to save the project, I find the below massage box

    And that after delete button 4 and redraw it.


    Hany Metry





    • Edited by Morgan Mosa Thursday, June 20, 2019 11:44 AM adjust
    Monday, June 17, 2019 9:16 PM

Answers

  • Dear Sir,

    Sorry I touch the mouse.

    Technically, I don't understand your reply!!!!!!!

    While I noticed that every form have other brown diagram below except the form which have the problem (form8WindLoadsforstripfooting) and when I click to show the diagram I got the following massage as per the photo below.

    Hany Metry




    What I was indicating is that you should not be calling the default instance of an object, in this case a click event of a form at runtime. A created instance is Dim f As New SomeForm.

    So now I have to ask, in the last screenshot, is this at design time or runtime? Sure looks like design time and if so I've seen this happen when someone has altered the designer file which one should never do but unsure if you have done this or not. Another possible reason is a corrupt code file.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    • Marked as answer by Morgan Mosa Friday, July 12, 2019 9:45 AM
    Tuesday, June 18, 2019 10:27 AM
    Moderator
  • Dear Sir,

    Sorry for delay but I was too busy and once I delete the problem form and re-do it all the problems are solved.

    Kind Regards,


    Hany Metry

    • Marked as answer by Morgan Mosa Friday, July 12, 2019 9:47 AM
    Friday, July 12, 2019 9:47 AM

All replies

  • Hi

    If you are trying to cause a Button Click to occur, try with the following format:


    Regards Les, Livingston, Scotland

    Monday, June 17, 2019 9:38 PM
  • Hi

    If you are trying to cause a Button Click to occur, try with the following format:


    Regards Les, Livingston, Scotland

    The code you suggest not solve the problem.

    Hany Metry

    Monday, June 17, 2019 10:00 PM
  • Okay I have to ask, are you really touching mouth or mouse?

    Either way my guess in the image below those are default instances of the form else they would not be in green. You need to call the created instance not the default instance of the form.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Monday, June 17, 2019 10:27 PM
    Moderator
  • Dear Sir,

    Sorry I touch the mouse.

    Technically, I don't understand your reply!!!!!!!

    While I noticed that every form have other brown diagram below except the form which have the problem (form8WindLoadsforstripfooting) and when I click to show the diagram I got the following massage as per the photo below.

    Hany Metry




    • Edited by Morgan Mosa Tuesday, June 18, 2019 5:26 AM adjust
    Tuesday, June 18, 2019 4:14 AM



  • Hi,

    The error shows there is no sub named Buuton4_Click(sender As Object, e As EventArgs) in Form8WindLoadsforstripFooting Class,you need to confirm it.

    Best Regards,

    Alex



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 18, 2019 5:46 AM



  • Hi,

    The error shows there is no sub named Buuton4_Click(sender As Object, e As EventArgs) in Form8WindLoadsforstripFooting Class,you need to confirm it.

    Best Regards,

    Alex



    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    No, there is sub named Buuton4_Click(sender As Object, e As EventArgs) , it is present


    Hany Metry

    Tuesday, June 18, 2019 7:02 AM
  • Dear Sir,

    Sorry I touch the mouse.

    Technically, I don't understand your reply!!!!!!!

    While I noticed that every form have other brown diagram below except the form which have the problem (form8WindLoadsforstripfooting) and when I click to show the diagram I got the following massage as per the photo below.

    Hany Metry




    What I was indicating is that you should not be calling the default instance of an object, in this case a click event of a form at runtime. A created instance is Dim f As New SomeForm.

    So now I have to ask, in the last screenshot, is this at design time or runtime? Sure looks like design time and if so I've seen this happen when someone has altered the designer file which one should never do but unsure if you have done this or not. Another possible reason is a corrupt code file.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    • Marked as answer by Morgan Mosa Friday, July 12, 2019 9:45 AM
    Tuesday, June 18, 2019 10:27 AM
    Moderator
  • Dear Sir,

    Sorry I touch the mouse.

    Technically, I don't understand your reply!!!!!!!

    While I noticed that every form have other brown diagram below except the form which have the problem (form8WindLoadsforstripfooting) and when I click to show the diagram I got the following massage as per the photo below.

    Hany Metry




    What I was indicating is that you should not be calling the default instance of an object, in this case a click event of a form at runtime. A created instance is Dim f As New SomeForm.

    So now I have to ask, in the last screenshot, is this at design time or runtime? Sure looks like design time and if so I've seen this happen when someone has altered the designer file which one should never do but unsure if you have done this or not. Another possible reason is a corrupt code file.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Dear Sir,

    Last screenshot in the design time.

    The design file is present in the folder and if it is altered, how to back it to its original case.

    The problem is too difficult, if I delete the problem form and re-do it again, that may solve the problem?????


    Hany Metry


    • Edited by Morgan Mosa Tuesday, June 18, 2019 6:32 PM adjust
    Tuesday, June 18, 2019 4:05 PM
  • Hi, 

    see the following link:

    https://social.msdn.microsoft.com/Forums/en-US/366e5d61-85e4-47c8-ac87-cbaac94a1078/error-hresult-efail-has-been-returned-from-a-call-to-a-com-component-vbnet-windows-10-vs-2015?forum=vbgeneral

    Best Regards,

    Alex


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, June 27, 2019 5:35 AM
  • Dear Sir,

    Sorry for delay but I was too busy and once I delete the problem form and re-do it all the problems are solved.

    Kind Regards,


    Hany Metry

    • Marked as answer by Morgan Mosa Friday, July 12, 2019 9:47 AM
    Friday, July 12, 2019 9:47 AM