locked
Http handler not getting recognized in server RRS feed

  • Question

  • User1057174103 posted

    I used AXCMS for developing my site using CMS. BY using AXCMS, every file will be created with an extension of .sample. I used the same and i developed it completely and was ready to be hosted. When i hosted the whole application in the server, hoshhh!!! I get error 404.0

    Server Error in Application "DEFAULT WEB SITE/AXCMSWEBLIVE_SAMPLE"

    Internet Information Services 7.0

    <fieldset><legend>Error Summary</legend>

    HTTP Error 404.0 - Not Found

    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    </fieldset>
    <fieldset><legend>Detailed Error Information</legend>
    Module IIS Web Core
    Notification MapRequestHandler
    Handler StaticFile
    Error Code 0x80070002
    Requested URL http://localhost:90/AXCMSweblive_Sample/RMS.Sample
    Physical Path D:\Release\AxCMS_Sample\AxCMSwebLive_Sample\RMS.Sample
    Logon Method Anonymous
    Logon User Anonymous
    </fieldset>
    <fieldset><legend>Most likely causes:</legend>
    • The directory or file specified does not exist on the Web server.
    • The URL contains a typographical error.
    • A custom filter or module, such as URLScan, restricts access to the file.
    </fieldset>
    <fieldset><legend>Things you can try:</legend>
    • Create the content on the Web server.
    • Review the browser URL.
    • Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.
    </fieldset>
    <fieldset><legend>Links and More Information</legend>This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.

    View more information »

    </fieldset>


    I dont know where it is going wrong though i have added the .sample extension using Add module mapping and also the same is set in config files. (The same setting i have used in my local)

    Please tell me if u ever i come across the same kind of issue. I am going mad on this issue for this full day...Cry   Help me out


    Thanks,

    Priya.





    Wednesday, July 8, 2009 10:38 AM

All replies

  • User191633014 posted

    use standart extension for your Handler:


    http://localhost:90/AXCMSweblive_Sample/RMS.aspx

    or

    http://localhost:90/AXCMSweblive_Sample/RMS.axd


    <httpHandlers>
       <add path="RMS.axd" verb="*" type="..........." />
      </httpHandlers>

    Thursday, July 9, 2009 6:48 AM
  • User1057174103 posted

     Thanks Stefan. But if i do so, i miss out the functionality that is provided by the CMS. since it need to be delivered yesterday, I had no other option and hence made thema as aspx files and have delivered it.

    Do you know any other open source CMS sytem to develop .net applications

    Friday, July 10, 2009 3:33 AM
  • User-1471482529 posted

    You could try dotnetnuke

    Thursday, July 23, 2009 12:51 PM