locked
[VS2012 RC] Error MSB3030 & error C1192

    Question

  • Can project add reference to a metro STATIC lib ?

    Get these error:

    LIB reference LIB
     error MSB3030: Could not copy the file "D:\MyProj\Debug\xxx.winmd" because it was not found. 

    EXE reference LIB
     error C1192: #using failed on 'D:\MyProj\Debug\xxx.winmd' 


    • Edited by Raptor K Sunday, June 3, 2012 4:42 AM
    Sunday, June 3, 2012 4:22 AM

Answers

  • I just solved this by setting "Project -> Properties -> Framework and References -> "Particular reference" -> Copy local " to false, but my static lib' s just pure c++ code without any need of cx winmd description.
    • Marked as answer by Raptor K Friday, August 10, 2012 2:20 AM
    Thursday, August 9, 2012 10:19 PM

All replies

  • Hi Rap,

    You add your winmd to your references in your project.  Then it will be available to your code.

    Here is some helpful documentation: http://msdn.microsoft.com/en-us/library/windows/apps/hh441572(v=vs.110).aspx

    Take a look at this sample to see how it is done in a project: http://code.msdn.microsoft.com/windowsapps/Hybrid-JavaScript-and-C-e6dc77fa

    -Jeff


    Jeff Sanders (MSFT)

    Monday, June 4, 2012 3:42 PM
    Moderator
  • No winmd. Does C++ static lib project generate winmd?


    C++ DX11

    Tuesday, June 5, 2012 2:04 AM
  • Right click on your project, go to properties..  Under "Configuration Properties" -> "General", select the item under "Project Defaults" labeled "Metro Style App Support".  Change this to "NO".

    Dan -


    This is my signature.

    Tuesday, June 5, 2012 4:29 PM
  • Setting "Metro Style App Support" to "No" for static library appears to be just replacing one problem with another. If you do that, when you try to add a reference to that library ("Common Properties" -> "Framework and References") you get the following warning:

    "Adding reference to 'MyStaticLib' is not recommended because it is not compatible with Metro style apps.  Would you still like to add this reference?"

    Wednesday, June 6, 2012 1:06 AM
  • I just solved this by setting "Project -> Properties -> Framework and References -> "Particular reference" -> Copy local " to false, but my static lib' s just pure c++ code without any need of cx winmd description.
    • Marked as answer by Raptor K Friday, August 10, 2012 2:20 AM
    Thursday, August 9, 2012 10:19 PM