locked
Unable to install application msi on Windows 7 RRS feed

  • Question

  • User1837071457 posted

    Hi,
    I have a ASP.Net 3.5 webservice and I created the msi using the Web Setup project. I used to build and deploy all the time previously when I had a XP machine, now that I have replaced with a new machine which has Windows 7, I am facing problems. When I double click the msi, all it does it brings up the first window and the caption reads Installation Incomplete and only action I can take at that point is cancel out of the window. I am unsure what the issue is. I tried looking at the event logs in the EventViewer to see if anything got logged in there, but found nothing. On this new machine I have enabled ASP.Net by going to the Framework64 folder of Microsoft.Net and registered using aspnet_regiis -i and that I was able to do by going to the VS command prompt as an Administrator. Any help is greatly appreciated.

    Thanks<!-- google_ad_section_end --> 

    Wednesday, January 27, 2010 11:02 AM

Answers

  • User1837071457 posted

    Thanks, in any case I figured out yesterday itself. It was not just due to the administrator role to install alone, I had to enable IIS 6 compatibility metabase as well. So after doing that I was able to install with Run as Adminisitrator on the setup.exe option when you right click on the file. The same option is not available on the msi file though. I wonder why. I will have to do some more digging.  After installing, I couldn't test since I had other issues with the mime type being not available. For which I had to run the servicemodelReg to re-install WCF. After that I was able to test my WCF service.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 28, 2010 10:54 AM

All replies

  • User-1659704165 posted

    Hi,

    Right click on MSI and select  Run as Adminstraor from Contex menu and The Chk

    Thursday, January 28, 2010 10:25 AM
  • User1837071457 posted

    Thanks, in any case I figured out yesterday itself. It was not just due to the administrator role to install alone, I had to enable IIS 6 compatibility metabase as well. So after doing that I was able to install with Run as Adminisitrator on the setup.exe option when you right click on the file. The same option is not available on the msi file though. I wonder why. I will have to do some more digging.  After installing, I couldn't test since I had other issues with the mime type being not available. For which I had to run the servicemodelReg to re-install WCF. After that I was able to test my WCF service.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 28, 2010 10:54 AM