locked
Empty search results on certain sites RRS feed

  • Question

  • Hi,

    I've got an issue with Sharepoint Search Service. Recently we found out that search stopped working on certain sites (let's say Site A, Site B) and it doesn't give any results now. I mean if you type "something" in searchbox on Site A and click search icon, the OSSSearchResults.aspx will be displayed with the text saying "We did not find any results for something". At the same time search works fine for certain Search Centers, i.e. if you type "something" in searchbox of the Search Center and choose "All Sites" in search area dropdown box, you'll see correct results which will include data from uppermentioned Site A and Site B.

    Plese note that:

    • Radiobutton "Allow this site to appear in search results?" is set to Yes in Site Settings.
    • ULS contains no errors or warnings (log-level: information/medium)
    • Some Search Centers in the farm return correct search results when searching in All Sites, while others say "We did not find any results"
    • Site A and Site B have several Alternate Access Mappings. But site-specific search doesn't work for any of them.
    • There are sites in the same Sharepoint farm where site-specific search works fine.

    I've looked through these threads:
    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/688b5c52-f478-463b-bc00-debfd0c3be2b
    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/a96091cd-4a05-4557-b09a-ff71ffee78e7
    but they don't seem to describe my case.

    So my questions are:

    1) Why can Sharepoint Search give empty results for certain sites?

    2) Is there any checklist of settings or something like that I can use to be sure that everything is set up correctly?

    Hope for your help.

    Thanks,
    Alexander

    Tuesday, June 19, 2012 3:21 PM

Answers

  • Alexander,

          So there are a variety of reasons why search might not be working on certain sites, but working fine on others.  I see you already ensured that the option for "allow this site to appear in search results" is set to yes, which is a good first test.  In your Search Service Application, check your content source and make sure the root site collection is there -- this should be the one that is in the DEFAULT zone in your Alternate Access Mappings (none of the other mappings should be in the content sources).

    With regards to Site A and Site B specifically, you can check the following:

    1) On Site A (or B) browse to the root site collection and go to "Site Actions" then "Site Settings".  Underneath the "Site Collection Administration" section, you will see an option for "Search Settings"

    2) In the "Search Settings" section, check if "Enable custom scopes" is checked or not, and if so, make sure your Enterprise Search Center URL is in the box.  Also, verify the Site Collection Search Results page looks something like "/_layouts/OSSSearchResults.aspx"

    3) Back into "Site Settings" click "Search Scopes" (underneath Stie Collection Administration) and see how many items are listed for "All Sites"

    4) Looking at the crawl log might be helpful for this situation as well, and it might be beneficial to make a new content source, just setup to crawl Site A and Site B, and see if anything shows up in the logs. However, I'm not so sure that the items are not being crawled, rather something is happening with the "Scope" (which you can also check in the Search Service Application -- Scopes (underneath the "Queries and Results" section)

    Let me know what you find!

    --Zach

    Tuesday, June 26, 2012 2:53 PM
  • Thanks Zach,

    Your advice was really helpful.

    So what did I find. The root cause was in Start Addresses (Search Service Application - Content Sources - Edit Content Source - Start Addresses). Some URLs were missing there, and the others were not necessary. This happened because we have 4 Web Applications in the farm. Two of them were created on http, i.e. with 'Use Secure Sockets Layer (SSL)' option set to 'No', while the other two - on https (with 'Use Secure Sockets Layer' set to 'Yes').

    Recently we decided to make all our sites (in all web apps) work over https. We used different web zones to set it up. Then we changed http-URLs in Start Addresses to corresponding https-URLs. And that's our mistake because site-specific search stopped working for the sites from the web apps that were initially created on http.

    Shortly speaking I found out that 3 things worth consideration:

    1) Public URL of Web App (when it was created)
    2) Default zone URL
    3) The URL you include in Start Addresses

    In my case site-specific search started working only when I made all three the same http-URL for each web app that was originally created on http.

    Friday, July 13, 2012 11:42 AM

All replies

  • Alexander,

          So there are a variety of reasons why search might not be working on certain sites, but working fine on others.  I see you already ensured that the option for "allow this site to appear in search results" is set to yes, which is a good first test.  In your Search Service Application, check your content source and make sure the root site collection is there -- this should be the one that is in the DEFAULT zone in your Alternate Access Mappings (none of the other mappings should be in the content sources).

    With regards to Site A and Site B specifically, you can check the following:

    1) On Site A (or B) browse to the root site collection and go to "Site Actions" then "Site Settings".  Underneath the "Site Collection Administration" section, you will see an option for "Search Settings"

    2) In the "Search Settings" section, check if "Enable custom scopes" is checked or not, and if so, make sure your Enterprise Search Center URL is in the box.  Also, verify the Site Collection Search Results page looks something like "/_layouts/OSSSearchResults.aspx"

    3) Back into "Site Settings" click "Search Scopes" (underneath Stie Collection Administration) and see how many items are listed for "All Sites"

    4) Looking at the crawl log might be helpful for this situation as well, and it might be beneficial to make a new content source, just setup to crawl Site A and Site B, and see if anything shows up in the logs. However, I'm not so sure that the items are not being crawled, rather something is happening with the "Scope" (which you can also check in the Search Service Application -- Scopes (underneath the "Queries and Results" section)

    Let me know what you find!

    --Zach

    Tuesday, June 26, 2012 2:53 PM
  • Thanks Zach,

    Your advice was really helpful.

    So what did I find. The root cause was in Start Addresses (Search Service Application - Content Sources - Edit Content Source - Start Addresses). Some URLs were missing there, and the others were not necessary. This happened because we have 4 Web Applications in the farm. Two of them were created on http, i.e. with 'Use Secure Sockets Layer (SSL)' option set to 'No', while the other two - on https (with 'Use Secure Sockets Layer' set to 'Yes').

    Recently we decided to make all our sites (in all web apps) work over https. We used different web zones to set it up. Then we changed http-URLs in Start Addresses to corresponding https-URLs. And that's our mistake because site-specific search stopped working for the sites from the web apps that were initially created on http.

    Shortly speaking I found out that 3 things worth consideration:

    1) Public URL of Web App (when it was created)
    2) Default zone URL
    3) The URL you include in Start Addresses

    In my case site-specific search started working only when I made all three the same http-URL for each web app that was originally created on http.

    Friday, July 13, 2012 11:42 AM