VS2010 designer errors with x64 configuration


  • With an empty x64 WPF project I can't import the project's own namespace. Can the WPF designer in VS2010 be used on a x64 project, or what am I doing wrong?

    Below are the steps that reproduce this problem.

    Using:Microsoft Visual Studio 2010 pro Version 10.0.30319.1 RTMRel
    Microsoft .NET Framework Version 4.0.30319 RTMRel

    Launch VS2010 IDE
    File > New Project > WPF Application
     Targeting .NET Framework 4
     Name = WpfApplication1
     Solution name = WpfApplication1

    Open MainWindow.xaml in xaml editor
    add (xmlns:local="clr-namespace:WpfApplication1")

    Designer error "Undefined CLR namespace. The 'clr-namespace' URI refers to a namespace 'WpfApplication1' that is not included in the assembly."
    Build solution (successful)
    Error disappears

    Open Configuration Manager
    Click Active solution platform. Select <New...>
    Select new platform as x64. Click OK. Close Configuration Manager.

    Error reappears: "Undefined CLR namespace. The 'clr-namespace' URI refers to a namespace 'WpfApplication1' that is not included in the assembly."

    Rebuild solution (successful)
    Error remains and designer is now useless.

    This may be similar to a previous post that strayed off topic.

    Can the WPF designer in VS2010 be used on a x64 project, or what am I doing wrong?
    If x64 isn't currently supported is there a plan to support it in the future?


    Wednesday, April 28, 2010 4:31 PM

All replies

  • Did you get anywhere with this? I'm currently experiencing the same problem, under the same conditions. My project references a bunch of 32-bit DLLs which contain unmanaged code, so I suspect it is somehow related to that, though changing the build target to x86 didn't help...

    The designer works so long as all the namespace references are to external assemblies. As soon as I try to reference a namespace in the application main assembly, it chokes and falls over with the same error message.

    Thursday, August 05, 2010 4:26 PM
  • *BUMP* I have exactly the same issue when building for x64, which as stated above, due to the refences not resolving and stops the WPF designer in it's tracks.

    Compiling goes fine and the app works as normal though.

    As soon as I switch over the platform target to 'Any CPU' the errors go and the references are resolved. (I'm referencing an internal class, not external DLLs)

    Monday, October 11, 2010 2:42 PM
  • *BUMP*


    Still seeing this.  It builds successfully, but when attempting to load the designer, it barfs with the error:

    Undefined CLR namespace. The 'clr-namespace' URI refers to a namespace '{0}' that is not included in the assembly.


    Edit: I should point out that I'm already using "Any CPU" for the target platform.  I'm also targeting .NET 3.5.

    Thursday, October 14, 2010 1:13 AM
  • *BUMP* again

    We all have the problem at my company. so it's definitely not a machine-specific issue. We are targeting .NET 4.0, and have a solution with an x64 targeting .exe, and a number of assemblies that target "Any CPU".

    Monday, December 13, 2010 8:48 AM
  • * BUMP * 

    Same as other posts.  I loose designer support in 64 bit when referencing local namespace in xaml as described in OP's post.


    I just filed a bug report on connect as it appears this is not just me.  It's easily reproducible as well. 




    Friday, December 17, 2010 6:41 PM
  • I thought I would post the result from the bug report on connect in case anyone else comes across this post while searching.  

    Text from bug report response:

    Thanks for bringing this issue to our attention.  Unfortunately this is not something that we are going to be able to address in the current release or a SP release of Visual Studio, however we will continue to look into addressing this in a future release of Visual Studio.  In the mean time, as a work around, you can continue to do you development in the 32 bit environment, and then when you are ready to deploy build in the 64 bit environment.

    Monday, January 10, 2011 10:29 PM
  • have you tried giving it a fully qualified namespace by including the assembly?


    not sure if that would help.

    Monday, January 10, 2011 11:21 PM