locked
Word 2010 MSI deployment on Windows 7 machines RRS feed

  • Question

  • Hello,

    I had created a VSTO plugin using VS2008 for Word 2007 and we used to deploy it on Windows XP machines. Now that we are moving to Windows 7, I created the plugin using VS2010 and deployed the MSI on a Windows XP machine. It gets saved to C:\Program Files\SmartPlugin\SmartPlugin for Office 2010\...with all the files (.dlls, .vsto, etc).

    When I deploy the same MSI on Windows 7 machine, it doesn't get deployed in this path. I get loaded under C drive. The reason being is it 32 bit and needs to be saved under the C:\Program Files (x86)\.... path. I went to change this setting in the registry but the moment I change the manifest value, my project no longer builds. I went through the msdn posts and discussions but couldn't find something I was looking for.

    I would like to know how do I change the setting and be able to build the project successfully so that when I deploy the MSI on Windows 7 machine, it saves the files to C:\Program Files (X86)\SmartPlugin\SmartPlugin for Office 2010\....all files

    Thanks in advance,

    May

    This is the current path of the registry file.

    [HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\SmartPlugin]
    
    
    
    "Description"="SmartPlugin For Word 2010"
    
    
    
    "LoadBehavior"=dword:00000003
    
    
    
    "FriendlyName"="SmartPlugin For Word 2010"
    
    
    
    "Manifest"="C:\\Program Files\\SmartPlugin\\SmartPlugin for Office 2010\\SmartPlugin.vsto|vstolocal"

     

     



    • Edited by May1006 Tuesday, July 12, 2011 12:10 PM spelling mistake
    Monday, July 11, 2011 4:53 PM

Answers

  • Thanks for the answer Tom. It turned out to be really a simple thing which I missed. I had the admin rights on the Windows 7 machine but I didn't click on "Run as Administrator" when I was trying to install it. Thats the reason it was getting installed under the C drive and not under the path I was looking for. Well but now it does.

    So for Windows 7 you have to actually run the software to be installed as an Administrator rather than having just the Admin rights on the machine.

    Regards,

    May1006

    • Marked as answer by May1006 Tuesday, July 19, 2011 1:23 PM
    Tuesday, July 19, 2011 1:23 PM

All replies

  • Hi May1006,

    Thanks for posting in the MSDN Forum.

    I think I must clarify some questions for:

    1.       The add-in which developed on Platform target 32-bit only can work with Office (32-bit), and 64-bit add-in can only work with Office (64-bit).

    2.       Office(32-bit) in 64-bit Windows operation System uses different registry hive than in 32-bit.

     So, based on you description I can give these result to you:

    1.       If your Office is 64-bit. You add-in will not work at all.

    2.       If your Office is 32-bit. You need write the key at this place: HKEY_CURRENT_USER\Software\Wow6432Node\Microsoft\Office\Word\Addins\SmartPlugin

    I hope it can help you.

    Have a good day,

    Tom

    reference: http://blogs.msdn.com/b/vsto/archive/2010/04/09/deploying-com-add-ins-for-64-bit-office-using-visual-studio-saaid-khan-for-nathan-halstead.aspx


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, July 13, 2011 10:05 AM
  • Thanks for the answer Tom. It turned out to be really a simple thing which I missed. I had the admin rights on the Windows 7 machine but I didn't click on "Run as Administrator" when I was trying to install it. Thats the reason it was getting installed under the C drive and not under the path I was looking for. Well but now it does.

    So for Windows 7 you have to actually run the software to be installed as an Administrator rather than having just the Admin rights on the machine.

    Regards,

    May1006

    • Marked as answer by May1006 Tuesday, July 19, 2011 1:23 PM
    Tuesday, July 19, 2011 1:23 PM
  • Hi May1006,

     

    I’m glad to hear you solved your issue. Thanks for sharing your experience here. It will be very beneficial for other community members who have similar questions to see how you solved your issue.

     

    Have a good day,

     

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, July 20, 2011 1:27 AM