locked
Azure Storage Account, turning off GeoReplication with PowerShell not working RRS feed

  • Question

  • Hi,

    Has anyone had any issues with turning off GeoReplication on the storage accounts by using PowerShell?  I'm issuing the following command, which returns true, but upon checking GroReplication is still enabled.

    Set-AzureStorageAccount -StorageAccountName $storageAccountName -GeoReplicationEnabled $false

    The above returns an OperationStatus of 'Success' which would assume that the command has completed successfully.

    However checking the portal etc, and the GeoReplication is still set  as shown below:

    StorageAccountDescription : 
    AffinityGroup             : test
    Location                  : 
    GeoReplicationEnabled     : True
    GeoPrimaryLocation        : West Europe
    GeoSecondaryLocation      : North Europe
    Label                     : teststorageaccount
    StorageAccountStatus      : Created
    StatusOfPrimary           : Available
    StatusOfSecondary         : Available
    Endpoints                 : {https://teststorageaccount.blob.core.windows.net/, https://teststorageaccount.queue.core.windows.net/, https://teststorageaccount.table.core.windows.net/, https://teststorageaccount.file.core.windows.net/}
    AccountType               : Standard_GRS
    StorageAccountName        : teststorageaccount
    OperationDescription      : Get-AzureStorageAccount
    OperationId               : 305c48db-4532-27de-ab0c-00c552bf59fc
    OperationStatus           : Succeeded


    Marcus

    Monday, November 3, 2014 9:38 AM

Answers

  • Hi Marcus,

    It's a bug in the "Set-AzureStorageAccount" cmdlet, which has been identified and concerned team is working on it.

    You may pass the "-GeoReplicationEnabled $true" parameter to enable to the Geo-replication. But don't pass the -GeoReplicationEnabled Parameter if you want the Geo-replication to be turned OFF while creating the Storage account.

    However, if you want to turn OFF Geo-Replication for the storage account which is already created, you may Enable/Disable the Geo-replication option through Azure Portal.

    Click on the "Storage Account" --> "Configure"  and you may change it to "Locally Redundant" from "Geo-Redundant" option to disable Geo-Replication.

    Regards,

    Manu Rekhar

    • Marked as answer by Marcus_Dempsey Monday, November 3, 2014 10:56 AM
    Monday, November 3, 2014 10:50 AM

All replies

  • Hi Marcus,

    It's a bug in the "Set-AzureStorageAccount" cmdlet, which has been identified and concerned team is working on it.

    You may pass the "-GeoReplicationEnabled $true" parameter to enable to the Geo-replication. But don't pass the -GeoReplicationEnabled Parameter if you want the Geo-replication to be turned OFF while creating the Storage account.

    However, if you want to turn OFF Geo-Replication for the storage account which is already created, you may Enable/Disable the Geo-replication option through Azure Portal.

    Click on the "Storage Account" --> "Configure"  and you may change it to "Locally Redundant" from "Geo-Redundant" option to disable Geo-Replication.

    Regards,

    Manu Rekhar

    • Marked as answer by Marcus_Dempsey Monday, November 3, 2014 10:56 AM
    Monday, November 3, 2014 10:50 AM
  • Hi,

    Thought as much, that's what I've been doing.  Just wanted to check.

    Marcus

    Monday, November 3, 2014 10:56 AM