none
Create SDK for Compact2013 development in VS2013 RRS feed

  • Question

  • Hi,

    I am trying to build an SDK for my Windows Embedded Compact 2013 OS.

    I understand that it is possible to develop applications targeting WEC2013 using VS2013, however the SDK won't install on a development computer with VS2013 installed, it comes up with a warning message saying 'you must install Visual Studio 2012 before you can proceed with this SDK installation'.

    Am I correct that you can develop applications for a WEC2013 device using VS2013?

    How do I modify my SDK so that it will install on a machine with VS2013 installed on it?

    Thanks,

    Tom

    Sunday, July 6, 2014 1:35 AM

Answers

  • Looks like the SDK you are using is build with WEC2013 on VS2012 environment. To overcome this issue, you have to build the SDK for your device with WEC2013 on VS2013 environment. Then only it will allow you to install it on VS2013 for application development. SDK built with VS2013 is compatible for VS2012 but not viceversa.

    Please mark as answer, if it is correct.
    Please vote,if it is helpful post.
    Vinoth.R

    http://vinoth-vinothblog.blogspot.com
    http://www.e-consystems.com/windowsce.asp

    • Marked as answer by tomleijen Tuesday, July 8, 2014 9:07 AM
    Monday, July 7, 2014 7:21 AM

All replies

  • Looks like the SDK you are using is build with WEC2013 on VS2012 environment. To overcome this issue, you have to build the SDK for your device with WEC2013 on VS2013 environment. Then only it will allow you to install it on VS2013 for application development. SDK built with VS2013 is compatible for VS2012 but not viceversa.

    Please mark as answer, if it is correct.
    Please vote,if it is helpful post.
    Vinoth.R

    http://vinoth-vinothblog.blogspot.com
    http://www.e-consystems.com/windowsce.asp

    • Marked as answer by tomleijen Tuesday, July 8, 2014 9:07 AM
    Monday, July 7, 2014 7:21 AM
  • Hi Vinoth,

    Thanks for the reply.

    I'm trying to install WEC2013 platform builder on a VS2013 Pro 30 day trial environment but I'm having some trouble getting platform builder to integrate with VS2013.

    I have installed VS2013 on a freshly installed OS, installed the application builder and then installed platform builder (the latest version from Microsoft website) and have the following two problems:

    Shared source won't install through the installer (says it can't find the .msi file to download)

    I can't open my OSdesign project files, nor can I create a new OSdesign as there aren't any options in VS2013 to create a new OSdesign.

    Do you have any ideas why my install might not work?

    Thanks,

    Tom

    Tuesday, July 8, 2014 12:18 AM
  • you have to install in the following sequence and updates

    1. Install VS2013 and its updates (Update 2)
    2. Install latest Appbuilder
    3. Install Platform builder WEC2013 and its updates (I installed up to Update5)


    Please mark as answer, if it is correct.
    Please vote,if it is helpful post.
    Vinoth.R

    http://vinoth-vinothblog.blogspot.com
    http://www.e-consystems.com/windowsce.asp

    Tuesday, July 8, 2014 6:41 AM
  • Hi Vinoth

    Hi Michael,

    Thanks for the reply.

    I downloaded trial version of VS2013 from here: http://www.visualstudio.com/en-us/downloads/ so I'm pretty sure it's update 2 (Visual Studio Professional 2013 with Update2)

    I downloaded Windows Embedded Compact Toolkit from here: (http://www.microsoft.com/en-us/download/details.aspx?id=39268) which is different to the link suggested by Michael Verhagen in another thread. Although he suggested using update 2 and you are suggesting update 5 - I believe that the link I used is update 5.

    I will verify the version of VS2013 and try the other link to the compact toolkit.

    Thanks,

    Tom

    Tuesday, July 8, 2014 7:35 AM
  • The link Michael gave me worked, I will attempt to build an SDK tomorrow morning, but I'm pretty confident it will go smoothly.

    Thanks so very much for your help!

    Tom

    Tuesday, July 8, 2014 9:07 AM