locked
Help with IsPost and Validation RRS feed

  • Question

  • User-371148474 posted

    Hello, I have been trying to get around this page.... Actually, Its one Page1 expected to execute three queries simultaneously.

    First query

    @{ if (User Adress is EMpty from the database)  //condition 1{

    Show a form to update that

    submit button ="one" }

    else //condition 2 {

    Second query             if(!IsPost)  //condition 3 {

                Allow them explore the Page which hides the form in the first div since they have updated the necessary details required

               There is a form with few details here....If User clicks on Post it hides the and displays the condition in else statement

    submit button ="two"

                                 } Third query    else //condition 4 {

                           Allow User view details of what inserted after IsPost request was sent                    

      submit button ="three"                                      }

    }

    Problem here is this, in Condtion 2, condition 3 values don't get to condition 4.........

    I tried taking condition 4 to a new Page2..... After this, When condition 3 button is clicked,instead of redirecting to New Page2 with condition 4,

    Validation error for all forms  on the Page1 gets displayed including condition 1 form that has been hidden.....???????

    Saturday, July 5, 2014 11:56 PM

Answers

  • User-371148474 posted

    update 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, July 6, 2014 2:09 AM

All replies

  • User-371148474 posted

    update 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, July 6, 2014 2:09 AM
  • User-821857111 posted

    update 

    Doe that mean that the issue is resolved?

    Sunday, July 6, 2014 3:31 AM
  • User-371148474 posted

    Yes it is...........except for TinyMce editor.....

    If Validation is not valid on a post request, Tinymce Editor  becomes empty even after calling Request["description] 

    <textarea>@Request[""description]</textarea>

    Mike,  my issue with the <a href> hasn't been resolved yet....I thought you were going to look into it

    Sunday, July 6, 2014 8:03 AM