none
.Net framework 3.5 on Microsoft Windows Server 2003 (no service pack) RRS feed

  • Question

  •   How to Install .Net framework 3.5 on Microsoft Windows Server 2003 , Enterprise Edition (5.2, Build 3790) (3790.srv03_rtm.030324-2048)?. My windows 2003 server doesnt have any service pack installed and when I Install .Net framework 3.5 on it, it said I need to update my windows to service pack 1. I cant updated the requested service pack on my server due to verious application have been in production on it and I am very afraid of effection to those application with security and some other restriction which have fixed on the service pack 1 of windows 2003 server.  

             Could any body tell me how can I do to install .Net framework 3.5 on Windows 2003 server(no service pack) like what my server is configured now?  

    Thanks in advance,


    Veasna

    Monday, June 23, 2008 4:49 AM

Answers

  • Hi Veasna

    I just synced up with the setup team for .NET Framework for 3.5 and they confirmed that to install .NET Framework 3.5 on Win 2K3, you would need to upgrade to SP1. They are working on fixing the  MSDN documentation on the 3.5 System Requirements to reflect this information.

    Thanks
    Saurabh Gupta, PM, CFx, MSFT
    Saturday, June 28, 2008 12:12 AM
    Moderator

All replies

  • Hi Veasna

    Where are you installing hte Framework bits from? Have you tried installing the redist available at http://download.microsoft.com/download/6/0/f/60fc5854-3cb8-4892-b6db-bd4f42510f28/dotnetfx35.exe? The .NET Framework 3.5 install is supported on Win2K3 and shouldn't require the Service Pack to be already present on the machine. You should be able to install this on your machine without much trouble. For supported configurations you can refer the MSDN article at http://msdn.microsoft.com/en-us/library/bb882520.aspx.

    HTH
    Saurabh Gupta, PM, CFx, MSFT
    Monday, June 23, 2008 11:21 PM
    Moderator
  •      I have download the .Net framework 3.5 through the link you have mentioned but when I setup, it still need request me to update my windows 2003 server to service pack 1. What should I do now to resolve it?

    Your help is very helpfull to me, now.

    Best regards,


    Veasna
    ;)
    Friday, June 27, 2008 1:36 AM
  • Hi Veasna

    I just synced up with the setup team for .NET Framework for 3.5 and they confirmed that to install .NET Framework 3.5 on Win 2K3, you would need to upgrade to SP1. They are working on fixing the  MSDN documentation on the 3.5 System Requirements to reflect this information.

    Thanks
    Saurabh Gupta, PM, CFx, MSFT
    Saturday, June 28, 2008 12:12 AM
    Moderator
  • Hi Saurabh Gupta,

        This mean that I can not have another alternative possibility to install .Net framework 3.5 without upgrade my Windows 2003 server to service pack 1?

    Thanks,

    Veasna

     

     


    ;)
    Monday, June 30, 2008 3:16 AM
  • Hi Veasna

    Yes, your understanding is correct. You would need to upgrade to Win 2K3 SP1 before you are able to install .NET Framework 3.5.

    Thanks
    Saurabh Gupta, PM, CFx, MSFT
    Tuesday, July 8, 2008 8:48 PM
    Moderator