none
Edit Page in Pages library - Access denied error RRS feed

  • Question

  • Hi,

    I have few users who have full control on the site collection. Master page is customized in the site. When users try to edit the page in pages library, they are getting "Sorry, this site hasn't been shared with you".

    How to fix this?

    Thanks

    Wednesday, March 30, 2016 10:01 AM

Answers

  • Hi Venkatzeus,

    For your issue, check the following:

    Make sure the user have full control on the pages library. permission have not been broken on the Pages library and on the Publishing Page.

    Make sure the use have permission on the master page and the master page have been published as an major version.

    If the issue still exists, I would suggest you reset the master page to the definition.

    Navigate to Site Settings->Reset to site definition->you can reset the master page to the definition.

    Besides, similar issue post for your reference:

    https://niranjanrao.wordpress.com/2012/07/27/sharepoint-2010-publishing-pages-access-denied-error/

    http://sharepoint.stackexchange.com/questions/60699/user-with-full-control-permission-is-getting-access-denied-message

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, March 31, 2016 7:26 AM
    Moderator
  • HI Venkat,

    Please try further granting users permission as the below.

    1. Go to Site settings > under Web Designer Galleries, access Master pages and page layouts.

    2. At the LIBRARY ribbon, Library Settings.

    3. Under Permissions and Management, Permissions for this document library.

    4. Grant the users permissions and then see if they can create pages in Pages library.

    You can choose either inheriting the permissions from parent, or keep the unique permissions and manage them in the library level.

    You can also check below few points:

    1. permission have been broken on the Pages library and on a Publishing Page
    2. the user accessing the page does not have read permission on the Pages Library
    3. minor version and moderation (content approval) is enabled on the Pages library, so publish a major version as content approval.

    --------------------------------------------------------------------------------------------------------------

    Thanks/ Siddheshwar Kohale

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful. It'll help other users who are visiting your thread for the similar problem.

    https://skdeveloper.wordpress.com/

    Wednesday, March 30, 2016 10:36 AM

All replies

  • HI Venkat,

    Please try further granting users permission as the below.

    1. Go to Site settings > under Web Designer Galleries, access Master pages and page layouts.

    2. At the LIBRARY ribbon, Library Settings.

    3. Under Permissions and Management, Permissions for this document library.

    4. Grant the users permissions and then see if they can create pages in Pages library.

    You can choose either inheriting the permissions from parent, or keep the unique permissions and manage them in the library level.

    You can also check below few points:

    1. permission have been broken on the Pages library and on a Publishing Page
    2. the user accessing the page does not have read permission on the Pages Library
    3. minor version and moderation (content approval) is enabled on the Pages library, so publish a major version as content approval.

    --------------------------------------------------------------------------------------------------------------

    Thanks/ Siddheshwar Kohale

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful. It'll help other users who are visiting your thread for the similar problem.

    https://skdeveloper.wordpress.com/

    Wednesday, March 30, 2016 10:36 AM
  • Hi Venkatzeus,

    For your issue, check the following:

    Make sure the user have full control on the pages library. permission have not been broken on the Pages library and on the Publishing Page.

    Make sure the use have permission on the master page and the master page have been published as an major version.

    If the issue still exists, I would suggest you reset the master page to the definition.

    Navigate to Site Settings->Reset to site definition->you can reset the master page to the definition.

    Besides, similar issue post for your reference:

    https://niranjanrao.wordpress.com/2012/07/27/sharepoint-2010-publishing-pages-access-denied-error/

    http://sharepoint.stackexchange.com/questions/60699/user-with-full-control-permission-is-getting-access-denied-message

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, March 31, 2016 7:26 AM
    Moderator